2 Replies Latest reply on Dec 15, 2009 3:40 PM by tntomek

    Not loading datavisualization.swc?


      Hi all:


      I'm working on a project where all the other developers are using FlexBuilder for Windows, but I'm a Linux guy and wanted to try to get it working.  I've installed FlexBuilder Linux a5 on Eclipse 3.5 (i386) running against jdk1.6.0_17.i586.  Our project uses the Flex SDK 3.3.0 with the data visualization library, so I installed that SDK in the sdks/3.3.0 folder.  Eclipse doesn't complain when compiling the projects, but when I deploy and try to debug my app, I get the following error:


      VerifyError: Error #1014: Class mx.controls::AdvancedDataGrid could not be found.


      The main thread is then suspended, and when I resume it, I get a Flash player alert containing the same error message (see attached screenshot).  Has anyone seen this behavior before?  Any help you can provide would be much appreciated!





      p.s. the following is the listing of the frameworks.libs folder in my SDK:


      > ls -l /usr/local/flexbuilder/flexbuilder-a5-112409.i386/sdks/3.3.0/frameworks/libs/
      total 2776
      drwx------. 2 tvolkert mts    4096 2009-03-05 14:21 air
      -rwxr-xr-x. 1 tvolkert mts  944877 2009-02-10 09:02 datavisualization.swc
      -rwxr-xr-x. 1 tvolkert mts   51283 2009-02-05 11:03 flex.swc
      -rwxr-xr-x. 1 tvolkert mts 1519746 2009-02-05 11:03 framework.swc
      drwx------. 4 tvolkert mts    4096 2009-03-05 14:15 player
      -rwxr-xr-x. 1 tvolkert mts  276353 2009-02-05 11:03 rpc.swc
      -rwxr-xr-x. 1 tvolkert mts   29759 2009-02-05 11:03 utilities.swc