1 Reply Latest reply on Dec 12, 2009 7:44 AM by kglad

    Flash not behaving on Firefox

    Curious Khan

      Hello, all.

       

      I have a problem in presenting Flash objects in Firefox.

      The code below works fine in IE, but not in Firefox.

       

      <html>
      <head>
      <title>Flash Test</title>
      </head>
      <body>
      <div style="position:absolute; left:100px; top:100px;">
      <object width="560" height="340">
        <param name="movie" value="http://www.youtube.com/v/Vg-eXlOCeT4&hl=en_US&fs=1&fmt=18"/>
        <param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"/>
        <param name="wmode" value="window"/>
        <param name="fmt" value="18"/>
        <embed src="http://www.youtube.com/v/Vg-eXlOCeT4&hl=en_US&fs=1&fmt=18" type="application/x-shockwave-flash" wmode="window" allowscriptaccess="always" allowfullscreen="true" width="560" height="340"/>
      </object>
      </div>
      <div style="position:absolute; left:400px; top:200px;">
      <object width="425" height="344">
        <param name="movie" value="http://www.10mg.nl/rabbit.swf"/>
        <!--param name="movie" value="http://www.youtube.com/v/HIZfTpyaqb0&hl=en_US&fs=1&fmt=18"/-->
        <param name="allowFullScreen" value="true"/>
        <param name="allowscriptaccess" value="always"/>
        <param name="wmode" value="window"/>
        <param name="fmt" value="18"/>
        <embed src="http://www.10mg.nl/rabbit.swf" type="application/x-shockwave-flash" wmode="window" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"/>
        <!--embed src="http://www.youtube.com/v/HIZfTpyaqb0&hl=en_US&fs=1&fmt=18" type="application/x-shockwave-flash" wmode="window" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"/-->
      </object>
      </div>
      </body>
      </html>

       

      The page is loaded with Flash player 9 in Firefox 3.5.5 for Windows XP.
      Please note that we can't afford to have the wmode value other than 'window.'
      Actually the phenomenon occurs only with the 'window' wmode.
      You can change the 'movie' value to whatever you want.

       

      When the page is first loaded in Firefox, it looks normal (or not).
      But when you move the mouse over the video clips or play them,
      they start stepping on each other's toes:

       

      The images are overlapped,
      and the intersection of the screen keeps flickering.

       

      We played with this and that attributes or parameters,
      put the clips in <iframe>s,
      but none of them succeeded.

       

      Does anyone have an experience like this?
      And does anyone know how to fix this?

       

      It'll be great if anybody could help me out of this.
      Thanks in advance.

       

      PS: I'm not sure whether it is Firefox or Flash that's causing this.
      If this is not the right place for a question like this, I offer my apology.

        • 1. Re: Flash not behaving on Firefox
          kglad Adobe Community Professional & MVP

          that's not correct embedding code.

           

          to confirm that's your problem, use the html file published by flash.  any problems?

           

          if not, you've confirmed the problem's cause.  either use the flash generated code correctly or use another embedding method like swfobject.

           

          if yes, repost the problem.