2 Replies Latest reply on Dec 14, 2009 11:44 PM by ceieneka

    Problem with FLVPlayback in HTML publish previev

    ceieneka

      Hi

      I am using a FLVPlayback to play a video on my project. Path to the video file is taken from xml file and loaded to FLVPlayback by action script, everything work properly in swf file. But when i publish this file and play as html, the movie never start. What can be wrong?

        • 1. Re: Problem with FLVPlayback in HTML publish previev
          funkysoul Level 4

          the only thing that can be wrong is that you have an absolute path to the flv file which is not visible when published, best is to place all the files in the same folder as your .fla file, link the flvplayback component to the new location of the flv (which should be the same location as the fla) and re-publish it, everything should work smoothly then.

          • 2. Re: Problem with FLVPlayback in HTML publish previev
            ceieneka Level 1

            I have relative path, when i link the flvplayback source by hand it works properly, but when i try to reload a movie by AS (using XML file), the flvplayback can't find a movie to play.

            That's how my XML looks like:

             

            <?xml version="1.0" encoding="utf-8"?>
            <videos>

             
                <vid>
                    <file>../video/contions.f4v</file>
                    <name>Contions</name>
                </vid>

                 ...

                 ...

            </videos>