17 Replies Latest reply on Oct 9, 2013 8:05 AM by rduane

    Director 11 Publishing Errors Xtras?

    itchardUK Level 1

      I really hope someone can help me with this problem. I can't find a solution online, and I don't want to pay for an upgrade to Director 11.5 until I know this will be sorted out.


      When Compiling my Projectors (Which I have been doing the same way for literally years) I have started receiving random errors which stop the publish and corrupt the final program.


      These errors happen sometimes, and not other times so I can't see a logical explanation for any of it and it is driving me insane.

      They Happen one after the other when Publishing


      "This file is locked. C:\Program F...port\NetFile"

      Click OK

      "This file is locked C:\Program F..ent\AWADCmpr"

      Click OK

      "Problem writing file 'E:\....(FilePath)': Having trouble saving this movie"


      Then it just stops....Doesnt publish anything


      If I take out the Xtras so that when the file is saved, only the required Xtras are included and publish again...


      "This file is locked. C:\Program F...t\Font Asset"

      Click OK

      Then I get hit with ...

      "This application requires an Xtra (Font...) that either does not exist or failed to initialize properly. Please make sure the appropriate Xtras are in the Xtras Folder(s)."


      The Program preview runs and it works fine !!



      Close the Program again..... Open it... Publish... and it Published the file no problem at all.. No errors... no problems. Works fine.


      Just doesnt make any sense.....


      I also have a random "C:\ Program F..t\GIF Asset" Error that appears every now and then... which mentions Animated GIF's.. (Which Im not even using !)



      I have recently upgraded to Windows 7, but had no problems at first with this.


      I have also completely reinstalled Director to make sure all Xtras that come with the package were installed...... and that had no effect either.



      Anyone got any ideas? be hugely appreciated.



        • 1. Re: Director 11 Publishing Errors Xtras?
          itchardUK Level 1

          Update about the random GIF Asset Message....



          When Publishing... Error appears


          "This file is locked. C:\Program F..ed GIF Asset"

          Click OK then...

          "This file is locked. C:\Program F..ore\TextXtra"

          Click OK then....

          "This application requires an Xtra (Animated GIF...) that either does not exist of failed to initialise properly. Please make sure the appropriate Xtras are in the Xtras folder(s)"

          Click OK then

          "Script Error. Continue?"

          Click no.. and everything crashes.....


          No idea what could be causing it all.

          • 2. Re: Director 11 Publishing Errors Xtras?
            Sean_Wilson Adobe Community Professional

            Do you have admin privileges on the machine you're publishing from?


            It looks like you have some strange permissions set on the authoring application folder, or a sub- or super- folder. I have never seen error messages about xtras being locked when compiling a projector. Make sure you have no files open or running in authoring, or Director-file tool xtras open and running.

            • 3. Re: Director 11 Publishing Errors Xtras?
              itchardUK Level 1

              Hi Sean, Thanks for replying,


              I have full admin privileges on my machine, and the setup hasnt changed in all the 10 years I have been using various versions of Director which is why I can't work out a logical solution for me having these problems.


              I've never seen or heard (or can find anywhere else on the internet) of people having this problem with xtras being locked while publishing.

              No files are open, or running that may cause a conflict while authoring...


              Just as an example... after my second UPDATE post on here, about an hour later I made a changed an image within the file I was using to make an update to the program, Published it, and it worked fine...  Yet if I do it again now.. It would be just as likely to have the random error messages appear again...


              Very frustrating.


              I wish the error messages gave me more info, but they all seem shortened and abbreviated when showing a path of the Xtra, so I can't even investigate the file in question


              Thank you very much for your time... any other ideas of course would be appreciated

              • 4. Re: Director 11 Publishing Errors Xtras?
                rc_mantis Level 1

                I get exactly these random error messages. As a result my projectors do not work. I only have Director MX though.


                This problem did not exist with XP but happened as soon as I installed Windows 7. I am set as Admin and have tried altering permissions for the xtra folder, with no luck

                • 5. Re: Director 11 Publishing Errors Xtras?
                  itchardUK Level 1

                  I still havent fully sorted out Director...... I havent updated to 11.5 because I have a friend who has, and he still gets the messages.


                  I did manage to be able to work out a lengthy(ish) way to publish the projectors.


                  I had a conflict with an ICON i was using, I now dont use any icons at all......


                  Then, every time I go to publish, I have to MODIFY > XTRAS... and remove all the xtras in the folder. Once you save and compact, it adds back in the Xtras it needs for the movie. The projector will then let me publish fine.


                  Its a pain, but might be worth a try to get you through what you need to do.

                  • 6. Re: Director 11 Publishing Errors Xtras?
                    rc_mantis Level 1

                    awww thankyou for getting back I will definately try that next time, at

                    the moment I've faffed with moving everything back to my old XP computer just to create the projector , not a permenant solution, I hope ...

                    • 7. Re: Director 11 Publishing Errors Xtras?
                      itchardUK Level 1

                      Oh man, that sounds like a pain.


                      Well fingers crossed it helps.


                      I have a horrible feeling that Adobe aren't that bothered about Director anymore.... seems to be dwindling ! Hence the lack of updates etc.. Big shame.

                      • 8. Re: Director 11 Publishing Errors Xtras?
                        rc_mantis Level 1

                        Yes I think so too.

                        I like to not have to make Disk based products anymore, now the internet's so much easier to work with.

                        • 9. Re: Director 11 Publishing Errors Xtras?
                          miche_r Level 1

                          I got same problems with Windows 7 & Director MX 2004. I changed the location of the project folder (including *.dir files), and it helped. Now the project folder is on my local C: drive, and no more problems about locked xtras.

                          • 10. Re: Director 11 Publishing Errors Xtras?
                            Wolfgang Herold Level 2

                            you are admin on your pc, but since Win7 you have not the full rights as in XP.



                            set UAC to the lowest security.

                            right click the Director icon and under compatiblity set "always start as administrator".

                            Also the "program files" or "program files(x86)" do not give you full acces and permissions, as these folders now belong to the system.

                            So it is better to install director MX2004/Dir11/11.5 not to these folders. Just use e.g. C:\myprogs\Director\

                            Thats why Director ( Dir11.5 also) is not on Adobes compatibility list for Win7


                            For the projector after then, do the same trick with right click and compatibility mode setting.

                            As all in a projector included xtras are expanded to the temp folder, you'll have also problems with accessing this folder caused by permissions.

                            Best way is to include no xtra anymore. Just create a xtra folder in the folder where the projector sits and put in there all the xtras you need  for

                            full funtion of the projector.



                            as i am native german speaking (Austria), my PC is set up in german.

                            So my description for settings or folder names can be a little different to that in english setups, as i translated it from my german settings.



                            i develop with MX2004 and Dir11.5 on Win7-64bit since 14 months with no problems




                            • 11. Re: Director 11 Publishing Errors Xtras?
                              segaftw Level 1

                              possible solution

                              cheap and dirty

                              drop the Adobe Director folder in the public folder
                              C:\Users\Public\Adobe Director 11

                              publish 1 or 2 times

                              keep fingers crossed

                              • 12. Re: Director 11 Publishing Errors Xtras?
                                Adam-C Level 2

                                Have you tried publishing your projector without any Xtras and then including the required Xtras in a "Xtras" folder alongside the projector? (I see Wolfgang also suggests this workaround). As well as possibly fixing the problem, this has the added advantage of making your projectors launch MUCH faster (cos the Xtras don't have to be unpacked from the program file before they can be used).


                                In response to rc_mantis' saying he's moving stuff to XP and back, perhaps it would be more convenient to run a Windows XP VM that you could launch in your Win7 environment but that would allow you to publish without restarting or moving your project to another machine - just chuck it across to the VM. In fact, if you used the VM as your developing environment you may avoid the problem altogether, but still have all your Win7 email etc. available too.


                                "Script Error. Continue?"

                                Click no.. and everything crashes.....


                                This is the standard error that you get when a projector encounters a scripting error, which is happening in this case because the required Xtras can't be accessed. If you want to see a full error message (as you would see in author mode) tick the "Display full script error text" option under the "Projector" tab in Publish Settings. (it will tell you which Xtra couldn't be loaded if nothing else).


                                Ultimately though I tend to agree with Wolfgang that this sounds like a permissions problem, and think his solution should work. However, I've got many disc-based products "out there" that encounter pretty much every type and flavour of computer and OS you can imagine. I've had plenty reports about problems with Mac OSX Lion, but nothing about incompatibilities with Win7. This would suggest to me that the problem only occurs when publishing the projector, and that a successfully published projector should run just fine on Win7 without you needing to make any other changes to the exe file after publishing.

                                • 13. Re: Director 11 Publishing Errors Xtras?
                                  Steve Hagenlock Level 1

                                  Open your Windows Services control panel and look for the "Microsoft Antimalware Service". Disable it, stop it and reboot.

                                  Then try publishing your projectors.


                                  This was plaguing me in Windows 7 / Director MX 2004 and that was the fix.  After turning it off, I never had that kind of error again until the service got turned back on again, somehow.  Sad, but true.  I figured this was a Director MX 2004 issue and that Director 11 would have addressed it.



                                  • 14. Re: Director 11 Publishing Errors Xtras?
                                    pallottadesign Level 1

                                    Running 11.5 on Windows 7 here...similar problems. Try publishing to a new, empty folder. Attempting to publish to a folder that already has a projector or the DIR file in it results in the "locked" etc. error messages.

                                    • 15. Re: Director 11 Publishing Errors Xtras?
                                      CAnuszczyk Level 1

                                      To overcome this type of issue, this is what I have done for the last 2 years successfully:


                                      Each movie's publish settings are set to go to c:\deploy\lastpublish\moviename.exe  (I create projectors)

                                      I create a folder called "c:\deploy\staging". 

                                      Into this I copy all of my original dir files and cast members. 

                                      I then open and publish each movie. (I actually use autoit scripts to automate the process)

                                      This works and I have no more of the "locking" problems.

                                      It also helps because the publishing process changes the movies so that the casts are pointing at the compressed, encrypted versions (cct, cxt)  Since I'm publishing a copy I avoid this annoyance.


                                      - Carl

                                      • 16. Re: Director 11 Publishing Errors Xtras?
                                        fuzzgrr Level 1



                                        I just experienced this issue today for the first time. I solved it by bringing my entire project to a local hard drive (it's small so this was easy). Like others who have answered above, I've been using Director for years with no issues. We have two licenses of Director 11.5, and both are running WinXP. Both machines experienced the issue. The errors we got were many and various, and seemed different every time we tried to compile.


                                        Today, we have had network file transfer issues reported by some other users. We always figure if you have two mysteries, they might be related. So, the mysterious network issues + mysterious compiling issues = bring it local. A little bit ironic since Director is complaining about local files bein locked. Go figure.


                                        Not saying we've solved it, but at least we can get our project shipped today. Worth a try if you're still stuck...



                                        • 17. Re: Director 11 Publishing Errors Xtras?
                                          rduane Level 1

                                          Hey, thanks everybody, but most especially Steve Hagenlock.  Just started trying to publish from Dir11.5 on Windows 8 and was having the same issues about the locked Xtras.  Looked in the control panels, and although there was no "antimalware service" anymore, there was something called "Windows Defender".  Turned that off, and lo and behold I could publish again!


                                          I also took the advice about moving the Director app - and my apps - out of the Program FIles folder.  Everything seems to be peachy now.