4 Replies Latest reply on Dec 27, 2009 11:43 PM by vinu_kumar_cf

    CFBuilder Beta 3 Mac Installer Problem

    matthew.zimmer

      This may be a bit premature and it could very well be an issue with my computer, or more likely PEBKAC, but I wanted to just get it out there and hopefully have a place for others experiencing my issue to find the solution they are looking for.

       

      I've done the following to experience my issue:

       

      1. Download CFBuilder Beta 3 for mac from Adobe Labs
      2. Unzipp the archive (filename: coldfusionbuilder_b3_install_mac_121709.zip)
      3. Run the installer (filename: cfbuilder_install)
      4. Enter password for OS X authentication
      5. ...and 5-7 seconds later...see [PROBLEM] below

       

      [PROBLEM]

      The installer icon simply dissapears from the Dock never to be seen or heard from again.  I have also tried installing via command prompt ($ ./cfbuilder_install.app/Contents/MacOS/cfbuilder_install) to no avail.

       

      [EXPECTED OUTCOME]

      The installer should go through the normal installation process on OS X and ultimately install CFBuilder Beta 3 Standalone on my 17" MacBook Pro (May 2008) with OS X Snow Leopard 10.6.2.

       

      [MY HARDWARE]

      Model Name:    MacBook Pro
      Model Identifier:    MacBookPro4,1
      Processor Name:    Intel Core 2 Duo
      Processor Speed:    2.6 GHz
      Number Of Processors:    1
      Total Number Of Cores:    2
      L2 Cache:    6 MB
      Memory:    4 GB
      Bus Speed:    800 MHz
      Boot ROM Version:    MBP41.00C1.B03
      SMC Version (system):    1.28f2

        • 1. Re: CFBuilder Beta 3 Mac Installer Problem
          vinu_kumar_cf

          Hi,

          Are you by any chance trying to install from a shared directory? If so move to another temp directory and install from there. Else you can look for the log under this folder and paste here:

           

          cfbuilder_install.app/Contents/Resources

           

          - Vinu

          Adobe ColdFusion Team

          • 2. Re: CFBuilder Beta 3 Mac Installer Problem
            matthew.zimmer Level 1

            Thank you for your response, Vinu.  There is no log file that is created in that location.  I did, however, find this:

             

            /Library/Logs/DiagnosticReports/cfbuilder_install_2009-12-27-021248_localhost.crash

             

            I have attached it to this message.  I appreciate your assistance.

             

            [UPDATE]

             

            From what I can tell right now, it looks like java is jacked up on my machine.  Anytime I try to run "java -version" or try to access my keystore I get "Trace/BPT trap" as my output and a crash log is added in the same location as where the attached crash log is.  I recently updated JVM for Mac to Update 1 via Apple Software Update a couple of weeks ago.  I have JDK 1.5 (32-bit), JDK 1.5 (64-bit), JDK 1.6 (32-bit), and JDK 1.6 (64-bit) installed so...

             

            What is even more strange for me is that I am able to install Beta 2 without issues.  It's installed in under 20 seconds.

            • 3. Re: CFBuilder Beta 3 Mac Installer Problem
              matthew.zimmer Level 1

              I know for a fact that my JVM was currupted some how which was the cause of my issue.  Given the lack of time to troubleshoot this coupled with the fact that Beta 2 expires on Jan 1, 2010 I decided to wipe my HDD and reinstall Snow Leopard.  All works as expected now.  I noticed that I now only have Java 1.6 (32-bit) and Java 1.6 (64-bit) installed after doing this.  And finally, I have not yet installed the JVM for Mac Update 1 yet.  I'd be curious what would happen if I tried it after updating Java.  Another day.  :-)

              • 4. Re: CFBuilder Beta 3 Mac Installer Problem
                vinu_kumar_cf Level 1

                Thanks for the confirmation. Mac Update 1 with JDK 6 should work well as

                expected. Let me know if you face any issues.

                 

                - Vinu