4 Replies Latest reply on Dec 17, 2009 1:55 PM by Flex harUI

    Deep Linking Oddity

    laxmidi Level 1

      Hi,

       

      I followed the deep linking  tutorial at http://www.switchonthecode.com/tutorials/flex-browsermanager-browser-history-and-the-back- button-fun# and got it working.

       

      In all of the examples of deep linking that I've seen, the URL looks something like:

                http://www.mydomain.com#a=1

      (The part after the # is arbitrary. Yours will look different.)

       

      My deep linking is working, but I get an extra '/' thrown in before the #. So in my case, it looks like:

                  http://www.mydomain.com/#a=1

       

      Any ideas as to why this is happening? In the tutorial, he has you change two lines from the HTML template to:

       

           <link rel="stylesheet" type="text/css" href="http://yoururl.com/history/history.css" />

       

           <script src="/files/history/history.js" language="javascript"></script>

       

      I was able to get it to work with Flex's default lines:

       

           <link rel="stylesheet" type="text/css" href="history/history.css" />

       

           <script src="history/history.js" language="javascript"></script>

       

      Deep linking wouldn't work if I changed the lines as the tutorial suggested. Does this have anything to do with the extra '/'?

       

      Any ideas as to why I'm getting the extra '/'?

       

      Thank you.

       

      -Laxmidi