13 Replies Latest reply on Sep 4, 2007 6:37 AM by HKabaker

    Files gone?!

    replikate
      I was working in Photoshop and Robohelp on an HTML Help project that I've have been working on for a weekes. Everything had been working fine. I recently upgraded from x5 to 6, and had no problems.

      Today, I was saving Photoshop image files (jpgs) into my an Image folder within the Project folder. I was inserting the same image files into my HTML Help project. Photoshop was able to find the Image folder within the Project folder. Robohelp had the entire project open from the Project folder (xpj file) and opened the files that were in the image folder.

      Then, I closed Photoshop and closed Robohelp. I should still be able to find the Project folder. I should still see the Image folder within my Project folder. I should be able to open the project in Robohelp again or open the Photoshop files again. Right?! But it's ALL GONE. Photoshop and Robohelp both act like the entire Project folder never existed. Where did it go?

      I have a backup from yesterday. But what happened to the Project folder I was working on today? Has anyone had this happen before?

      One caviat: I emptied my Recycle Bin (Win XP) while I was working. The bin included a lot of the image files I didn't need any more. However, the Project folder was NOT in the recycling bin. Copies of the same Project from a month ago were in the recycling bin. Are projects somehow linked when you copy them?
        • 1. Re: Files gone?!
          replikate Level 1
          Additional thought: I added one or two variables to nearly every page in the project today. Could that have caused a problem? - Kate
          • 2. Re: Files gone?!
            Peter Grainge Adobe Community Professional (Moderator)
            First there is no link between different copies. You say RH is acting like the folder never existed. Is it not listing the project when you open RH? Also have you looked via Windows Explorer?

            Where was the project, on your local drive?

            I have never seen anyone report this before so there has to be a logical explanation.

            • 3. Re: Files gone?!
              replikate Level 1
              RH is not listing the project in the list of available projects when I open it. I have looked in Windows by searching all drives using "ThisProjectName.xpj" and ".xpj", and it isn't to be found anywhere on my computer. It is as if it was erased from the drive.

              I don't work on any networked drives. I'm running WinXP on a Dell laptop. All my work is on the D drive, and never stored on a networked drive. I don't have a virtual desktop, so I can't reach my files from any other computer. I back up the work on a USB drive at the end of each day. So I have only lost one day.

              The Help project folder is a bit buried, since I work on a lot of projects in different groups. For clarity I'll call this Robohelp project folder "ThisHelpProject:" to distinguish it from the Project tab in the open Help project.

              The path to the two folders that I was working within yesterday are as follows:
              1) D:\Documents and Settings\kclark\My Documents\GXD PROJECTS\CURRENT GXD User Docs\Robohelp Docs\ThisHelpProject
              2) D:\Documents and Settings\kclark\My Documents\GXD PROJECTS\CURRENT GXD User Docs\Robohelp Docs\ThisHelpProject\Images
              [This Images folder I created in Windows and it is within the ThisHelpProject folder. It acts a bit strange for that reason.
              When I took Rick Stones class in July I learned I wasn't supposed to do this, but it was too late. He reminded me today that this isn't a good thing to do. But, I can't get rid of it now. So I just use it. Maybe I should stop using it?]

              Yesterday, I was working in the open Help project listed above, and I was also copying image files to the Image folder within the ThisHelpProject folder. At the end of the day, I did the following:
              1) I closed RH project, Photoshop, the ThisHelpProject folder, and the Images folder.
              2) I immediately looked for the ThisHelpProject folder to copy it to the backup drive, and couldn't find it. It had totally disappeared.

              I keep wondering if I did something stupid, but can't figure out what it was. If I accidently threw the ThisHelpProject folder into the recycling bin while I had the project open in RH, would RH act normally? I assumed that the automatic save feature in RH would throw an error message because RH couldn't save a project that is currently in the recycling bin.
              • 4. Re: Files gone?!
                HKabaker Level 2
                Could there be some confusion between what's on C and what's on D?

                When you save a project, where does RH want to put it?

                Harvey
                • 5. Re: Files gone?!
                  replikate Level 1
                  All my project files are stored on the D drive, in the exact path that I listed in an earlier message. Here is a sort-hand description of the path:
                  D:\...\...\My Documents\...\...\Robohelp Docs\ThisHelpProject
                  [This folder includes the .xpj file for the Help project, as well as all the other project files and folders.]

                  D:\...\...\My Documents\...\...\Robohelp Docs\ThisHelpProject\Images
                  [This folder includes images that I'm putting into the topics in the Help project. When I'm ready, I copy the images from another folder to this folder.]

                  As you can see I created a folder called "Images" within the "ThisHelpProject" and I'm storing images in there. These are the images I was manipulating in Photoshop, moving to the Images folder, and then adding to a topic in RH.

                  Here is where the RH program lives:
                  C:\Program Files\Adobe\RoboHelp 6.0

                  I don't know where RH wants to put the project. I think when I had the x5 version, RH tried to store the project in the Program Files on the C drive. I didn't let it do that. Both the C and D drives are on this computer (they are likely to be two partitions on the same drive since this is a laptop). I see both drives when I start the computer without an ethernet or wireless connection (such as in an airport or a car).
                  • 6. Re: Files gone?!
                    HKabaker Level 2
                    Cardinal rule 1 is that you never (or almost never) use Windows to insert, edit, delete or otherwise manipulate files in the project folder. And especially not when RH has the project open. When RH is open and you do anything in the Windows directory, and later you exit RH, project files are not properly updated.

                    You must import/insert an image into a topic from someplace outside the project directory. RH copies it into the project's main directory and makes entries in the project database. It builds the list for the Images "folder" in the project manager by scanning contents of the project folder and the database list. If it's in the database but not in the project directory, RH shows it as a missing image.

                    Yes, in some circumstances RH will let you navigate to an image already somewhere in the project folder. The insert command will put it into the topic. But because you have manually put it there, RH doesn't copy it into the main project folder, and doesn't register it in the database.

                    When RH subsequently opens the project and scans the main directory for images, it doesn't find them because they are in a subfolder, and doesn't list them as missing because they're not in the database.

                    I wish Adobe would put this in big red letters on the product box, if there were a product box anymore, on the splash screen and somewhere in the first window on launching the application.

                    Harvey
                    • 7. Files gone?!
                      replikate Level 1
                      Yes, I know that now. I created the folder on July 18th (in RHx5). I took Rick's class on the July 25th, where found out I shouldn't have done it. But it's too late. I can't move that Image folder out of the project because RH always replaces the folder when I delete it. And I don't have time to rewrite the entire site from scratch or from an older copy. So it seems I'm stuck with it.

                      Since then, I've moved from RHx5 to RH6.

                      Do you think that this extra folder I created has something to do with the entire project folder disappearing?

                      Any other way to delete that folder and save the project folder from disappearing again?

                      I've been working with that Image folder in my project folder for more than a month. It's mostly been working fine. The images never disappeared from the topics because I insert them as if they were in any location outside the project folder and it works fine.

                      Thanks, Kate
                      • 8. Re: Files gone?!
                        HKabaker Level 2
                        Hmmm. Sounds like a job for Captiv8r.
                        • 9. Re: Files gone?!
                          Captiv8r Adobe Community Professional & MVP
                          Hi Kate

                          Yes, I know that now. I created the folder on July 18th (in RHx5). I took Rick's class on the July 25th, where found out I shouldn't have done it. But it's too late. I can't move that Image folder out of the project because RH always replaces the folder when I delete it. And I don't have time to rewrite the entire site from scratch or from an older copy. So it seems I'm stuck with it.

                          If you have an additional folder to house your images, that shouldn't be a big deal. Particularly if RoboHelp keeps re-creating the folder. This tells you that RoboHelp is aware the folder is needed. This is because somewhere in one or more of your topics, there is a reference to the folder.

                          Since then, I've moved from RHx5 to RH6.

                          Do you think that this extra folder I created has something to do with the entire project folder disappearing?


                          There is no way I can fathom that creating a new folder in your project would make the entire project folder disappear. Personally, I'd be suspecting some other computer issue at play with this.

                          Any other way to delete that folder and save the project folder from disappearing again?

                          Okay, I'm confused now. What folder do you need to delete and why do you want to delete it?

                          Cheers... Rick
                          • 10. Re: Files gone?!
                            replikate Level 1
                            Okay, I'm confused now. What folder do you need to delete and why do you want to delete it?
                            >>>I meant to say "can I delete the Image folder that I created?" However, if the Image folder isn't causing a problem, then I won't worry about it.

                            There is no way I can fathom that creating a new folder in your project would make the entire project folder disappear. Personally, I'd be suspecting some other computer issue at play with this.
                            >>>Yes, it does sound more like a computer issue. This is a new computer too. I'll check in with the IT team.

                            Thanks tons for all your input! I'll go forward with this project as it is, and won't worry about it. I've redone most of the work I lost, so.... onward to meet the deadlines!
                            - Kate
                            • 11. Re: Files gone?!
                              clauatos
                              I have the same problems, but it's only with multimedia files (.swf). I insert the files in the Htm file, generate the Help and no problems can be seen. But when I close the Robohelp 6.0 and open it again, the mutimedia files lost their link in htm. I can the file in the Htm, but the project Multimedia folder have no file.
                              • 12. Re: Files gone?!
                                clauatos Level 1
                                Someone can help me? What can I do to resolve this? Thanks.
                                • 13. Re: Files gone?!
                                  HKabaker Level 2
                                  clauatos,

                                  Have you imported the .swf file into the baggage folder before putting it into the topic?

                                  Harvey