2 Replies Latest reply on Aug 7, 2008 7:23 AM by Godsbest

    Web Services: The Integrated Apache Axis SOAP Engine

      We are running CFMX 7 and we were just about to upgrade to CF8. However a few strange things have happened that have left us no time to work on the upgrade and wondering whether we should go ahead with the upgrade.

      We had several web services running on both our DEV and PROD servers and everything was working fine - PERFECT. Then three months ago, all of a sudden, the web services stopped working on our DEV servers. We tried to troubleshoot and could not find a reason as to why this happened. The same web services continued to work on our PROD servers until three weeks ago. In both instances no change was made to the code to cause the failure; as a matter of fact the same code works perfectly on our TEST servers. And, there were no server changes that would have caused the failure either.

      Whereas when the web services were working one could get XML output from the WSDL url now there is just a blank page. Programs on the same DEV and PROD servers that consume web services published elsewhere continue to work fine.

      How can we find out what is going on? How can we fix this?

      Thanks for you time - even for just reading this far .

        • 1. Re: Web Services: The Integrated Apache Axis SOAP Engine
          I'm not sure if you are still having this problem or exactly what it is, but one tool that I find extremely useful in developing and consuming web services is SoapUI by Eviware. Google it. It's free and very useful.

          • 2. Re: Web Services: The Integrated Apache Axis SOAP Engine
            Godsbest Level 1
            Hi Steve,

            Thank you very much for your response. We tried SoapUI. It was not of much help since it needs the WSDL document for the web service in order to test the web service. It is a great tool. We use SoapUI to test all our web services before we deploy them.

            The solution (or workaround) we were given by adobe is to create a blank Application.cfc file in the same folder as the web service CFC. The reason for this was not explained to us very well and we could find no documentation anywhere regarding this but, the web services are working fine.

            Best regards