4 Replies Latest reply on Jan 4, 2010 7:02 AM by Jochem van Dieten

    Startup error on first run as non-administrator

    Jochem van Dieten Level 4

      I installed CFBuilder Beta 3 on a Windows XP SP3 machine in the standalone configuration from the Administrator account. At the end of the installation I choose not to start CFBuilder, but instead started it manually from my own user account (Power User group) on the system. The startup consistently gave an error. Removed CFBuilder, installed it again, same problem.

       

      Then I used the "runas" command to start CFBuilder as Administrator. CFBuilder started up correctly. Closed it, started CFBuilder from my own account. This time no error, but instead I was prompted to select a different workspace since the workspace was in use. After selecting a different workspace everything is fine now.

       

      Logfile from a startup error attached.

        • 1. Re: Startup error on first run as non-administrator
          Bhakti Pingale

          Hi Jochem,

           

          When you started CFB did the error come up as a pop-up message? If yes, what was the error message?

           

          From the logs this doesn't really seem to be an issue because CFB was not started with 'Run as Administrator' option.

          We will have a detailed look into the logs and get back.

           

          Thanks!

          Bhakti

          • 2. Re: Startup error on first run as non-administrator
            Jochem van Dieten Level 4

            Bhakti Pingale wrote on 12/31/2009 7:56 AM:

            When you started CFB did the error come up as a pop-up message? If yes, what was the error message?

             

            It said something like "The bundle could not be resolved." and pointed

            to the log file.

             

             

            From the logs this doesn't really seem to be an issue because CFB was not started with 'Run as Administrator' option.

             

            I agree, usually when you have insufficient permissions you get a some

            io.SecurityException in the log, but this one is a bit weird.

             

            I don't think that all that many CF developers log in with a

            non-administrator account, so this may be a code path that gets

            exercised less frequently. I'll see if it is reproducible when I do a

            few more uninstall / install cycles this weekend.

            • 3. Re: Startup error on first run as non-administrator
              Bhakti Pingale Level 2

              Thanks Jochem.

              We will try the same at our end.

               

              -Bhakti

              • 4. Re: Startup error on first run as non-administrator
                Jochem van Dieten Level 4

                It is a permissions issue that is fixable by assigning additional

                permissions to the user. For now I have upgraded the Power Users group

                to Change permissions.

                 

                Before:

                C:\Program Files\Adobe>cacls "Adobe ColdFusion Builder"

                C:\Program Files\Adobe\Adobe ColdFusion Builder BUILTIN\Users:R

                                            BUILTIN\Users:(OI)(CI)(IO)(special access:)

                                                                      GENERIC_READ

                                                                      GENERIC_EXECUTE

                                            BUILTIN\Power Users:C

                                            BUILTIN\Power Users:(OI)(CI)(IO)C

                                            BUILTIN\Administrators:F

                                            BUILTIN\Administrators:(OI)(CI)(IO)F

                                            NT AUTHORITY\SYSTEM:F

                                            NT AUTHORITY\SYSTEM:(OI)(CI)(IO)F

                                            PRLT-J002\Administrator:F

                                            CREATOR OWNER:(OI)(CI)(IO)F

                 

                After:

                C:\Program Files\Adobe>cacls "Adobe ColdFusion Builder"

                C:\Program Files\Adobe\Adobe ColdFusion Builder BUILTIN\Users:R

                                            BUILTIN\Users:(OI)(CI)(IO)(special access:)

                                                                      GENERIC_READ

                                                                      GENERIC_EXECUTE

                 

                                            BUILTIN\Power Users:C

                                            BUILTIN\Power Users:(OI)(CI)(IO)(special access:)

                                                                            DELETE

                                                                            READ_CONTROL

                                                                            SYNCHRONIZE

                                                                            GENERIC_READ

                                                                            GENERIC_WRITE

                                                                            GENERIC_EXECUTE

                                                                            FILE_GENERIC_READ

                                                                            FILE_GENERIC_WRITE

                                                                            FILE_GENERIC_EXECUTE

                                                                            FILE_READ_DATA

                                                                            FILE_WRITE_DATA

                                                                            FILE_APPEND_DATA

                                                                            FILE_READ_EA

                                                                            FILE_WRITE_EA

                                                                            FILE_EXECUTE

                                                                            FILE_READ_ATTRIBUTES

                                                                            FILE_WRITE_ATTRIBUTES

                 

                                            BUILTIN\Administrators:F

                                            BUILTIN\Administrators:(OI)(CI)(IO)F

                                            NT AUTHORITY\SYSTEM:F

                                            NT AUTHORITY\SYSTEM:(OI)(CI)(IO)F

                                            PRLT-J002\Administrator:F

                                            CREATOR OWNER:(OI)(CI)(IO)F

                 

                With this change CFBuilder starts correctly.

                 

                Jochem