6 Replies Latest reply on Jan 1, 2010 8:07 AM by Captiv8r

    RoboHelp Hangs When Editing a Topic

    LarryTX Level 1

      I am using RoboHelp HTML 8.0.2 on a Windows XP machine. I started a brand new project two days ago and worked on it without a problem until this morning. The project is located on my local (C:\) drive, not on a network drive. This morning, I created a new topic, copied and pasted a couple of paragraphs into it from a Word document, inserted a couple of graphics, and did a little formatting. Now, when I try to do something as simple as bold a word, the memory usage jumps to over 50% (as reported by Task Manager), and RoboHelp freezes with the title bar reporting that it is unresponsive.

       

      Here's what I've tried thus far:

       

      1. I've deleted the new topic and recreated it. That didn't help. Once again, it would let me work a little bit in the topic and then freeze up.
      2. I've deleted the CPD file and reopened the project. That didn't help.
      3. I've followed the instructions on Peter Grainge's Web site on with regard to opening standalone projects, and that hasn't helped. (I didn't find any unused files or missing links, so doing that was little more than #2 above, except that I explicitly opened the project from the XPJ file this time, rather than from the recently used projects list on RoboHelp's opening screen.)

       

      I do note that each time I open this project, I get the flickering cursor going between an hourglass and arrow pointer, even though I installed the 8.0.2 patch long before I started this project. (By the way, the 8.0.1 patch was installed before the 8.0.2 patch.)

       

      I'm wondering what to do next. Should I re-apply the 8.0.2 patch? Should I delete both the CPD file and the XPJ file and attempt to open the project from the HHP file?

        • 1. Re: RoboHelp Hangs When Editing a Topic
          Peter Grainge Adobe Community Professional (Moderator)

          In Step 1 you don't say whether the project worked OK after you deleted the topic and before you recreated it. Let's rule out the problem being what you are bringing in from Word.

           


          See www.grainge.org for RoboHelp and Authoring tips

          Follow me @petergrainge

          1 person found this helpful
          • 2. Re: RoboHelp Hangs When Editing a Topic
            LarryTX Level 1

            Actually, I -- sort of -- figured it out. I tried completely retyping, rather than copying and pasting from Word, the last paragraph in the topic. Everything worked fine when I did that. I can't figure out what was coming in from Word that caused RoboHelp to hang. The HTML created from the copy and paste looked perfectly fine. (There were no embedded graphics, tables, etc. in the copy and paste.) There were no extraneous characters in the resulting HTML at all. That really worries me because we need to create a lot of material from existing Word documents. Copy and paste works best for us when doing that for lots of reasons. (Importing creates more problems than its worth.) I hate to think of having to retype everything.

            • 3. Re: RoboHelp Hangs When Editing a Topic
              Peter Grainge Adobe Community Professional (Moderator)

              That doesn't quite prove it was Word as you said you

              pasted a couple of paragraphs into it from a Word document, inserted a couple of graphics, and did a little formatting

              Try just pasting and then working on another topic. If it all works OK, do some formatting. Finally insert those graphics, I have a hunch they might be the problem. How are you inserting them?

               


              See www.grainge.org for RoboHelp and Authoring tips

              Follow me @petergrainge

              • 4. Re: RoboHelp Hangs When Editing a Topic
                ermphd

                Hi Larry,

                 

                MS word uses some hidden characters at the end of lines to define styles. It seems likely that your cut and pasts is causeing your issues. RH is a bit sensitive to weird characters. I have seen this with my searches in the AIR version.

                 

                If you can save the word docs as text, then the cut and paste will not have any weird characters in the file. You will of course loose formatting and depending on the type of docs, they may not look real pretty as simple text, but at least that willl save you lots of key strokes.

                 

                Ciao

                Ed

                • 5. Re: RoboHelp Hangs When Editing a Topic
                  LarryTX Level 1

                  I'm not copying and pasting the graphics at all. I'm doing a standard Insert > Image from the menu in RoboHelp. (That's one of many reasons I won't do an import from Word. I'd have to go back and rename every single graphic to something meaningful.) I am strictly copying and pasting text. The graphics worked just fine when I inserted them after retyping the text.

                   

                  The problem is that the whole thing appears very erratic. In that same topic, after I retyped two of the paragraphs, I was able to copy and paste other paragrpahs with no problem.

                   

                  One thing that occurred to me, though. Can RoboHelp handle Unicode characters? The paragraph in question happened to have an n with a tilde over it and an a with an accent.  The whole mechanics of RoboHelp seems to be lodged quite firmly in technology that is at least a decade old. I would be horrified if something in its price range in contemporary America couldn't handle those characters, but then, it is pretty antiquated. However, for those of us in the border States, those kinds of characters are part of everyday life. For over 15 years now, Dreamweaver has been able to handle Unicode.

                  • 6. Re: RoboHelp Hangs When Editing a Topic
                    Captiv8r Adobe Community Professional & MVP

                    Hi Larry

                     

                    I copy and paste from Word to RoboHelp all the time and never see issues. However, I add a step in there that you likely don't have.

                     

                    1. Copy text from Word
                    2. Paste into Notepad
                    3. Copy text from Notepad
                    4. Paste into RoboHelp

                     

                    The extra steps of pasting into Notepad and copying again serve the purpose of removing any of the hidden garbage Word adds.

                     

                    Cheers... Rick

                     

                     

                    Helpful and Handy Links

                    RoboHelp Wish Form/Bug Reporting Form

                    Begin learning RoboHelp HTML 7 or 8 within the day - $24.95!

                    Adobe Certified RoboHelp HTML Training

                    SorcerStone Blog

                    RoboHelp eBooks