8 Replies Latest reply on Jun 9, 2008 5:50 PM by jared_pariah

    Flex won't start

    jared_pariah
      I think I may have killed Flex. I have been working on another project that has required some messing around with Java, and now Flex won't start. It does give me the exit code = -1 when it tries to start. If anyone know how to fix this problem I would appreciate hearing how.

      Thanks in advanced,

      Jared
        • 1. Re: Flex won't start
          Garyl Woolworth Level 1
          You could try and "clean" the cached bundled data to see if that helps at all. Directions as follows.
          1. Go to install_drive\Program Files\Adobe\Flex Builder 3
          2. Open FlexBuilder.ini
          3. Add the following to the top of the file (not the bottom) and save it.

          -clean

          4. Launch Flex Builder
          5. Remove -clean after exiting Flex Builder
          • 2. Re: Flex won't start
            jared_pariah Level 1
            Thanks for the idea but that didn't seem to help. Any other suggestions?

            • 3. Flex won't start
              jared_pariah Level 1
              Here is the whole message, sorry but I couldn't copy the text.

              http://farm4.static.flickr.com/3071/2565041333_b90c4206bd.jpg?v=0"/>
              • 4. Re: Flex won't start
                Garyl Woolworth Level 1
                When you were messing around with JAVA were you using straight eclipse to develop with?
                • 5. Re: Flex won't start
                  jared_pariah Level 1
                  Hi I wan't using Eclipse, I was trying to install Java's wonderland, which required some path editing. I tried opening eclipse and I got an error I check the log and this is what it says:

                  !SESSION 2008-06-09 17:19:36.970 -----------------------------------------------
                  eclipse.buildId=M20050929-0840
                  java.version=1.5.0_13
                  java.vendor=Apple Inc.
                  BootLoader constants: OS=macosx, ARCH=ppc, WS=carbon, NL=en_US
                  Framework arguments: -keyring /Users/jaredbauer/.eclipse_keyring -showlocation
                  Command-line arguments: -os macosx -ws carbon -arch ppc -keyring /Users/jaredbauer/.eclipse_keyring -consoleLog -showlocation

                  !ENTRY org.eclipse.osgi 2008-06-09 17:19:39.311
                  !MESSAGE Application error
                  !STACK 1
                  java.lang.UnsatisfiedLinkError: /Applications/eclipse/configuration/org.eclipse.osgi/bundles/64/1/.cp/libswt-pi-carbon-31 39.jnilib:
                  at java.lang.ClassLoader$NativeLibrary.load(Native Method)
                  at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1822)
                  at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1715)
                  at java.lang.Runtime.loadLibrary0(Runtime.java:822)
                  at java.lang.System.loadLibrary(System.java:993)
                  at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
                  at org.eclipse.swt.internal.carbon.OS.<clinit>(OS.java:20)
                  at org.eclipse.swt.widgets.Display.createDisplay(Display.java:856)
                  at org.eclipse.swt.widgets.Display.create(Display.java:836)
                  at org.eclipse.swt.graphics.Device.<init>(Device.java:118)
                  at org.eclipse.swt.widgets.Display.<init>(Display.java:676)
                  at org.eclipse.swt.widgets.Display.<init>(Display.java:667)
                  at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:394)
                  at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:155)
                  at org.eclipse.ui.internal.ide.IDEApplication.createDisplay(IDEApplication.java:128)
                  at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:79)
                  at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
                  at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
                  at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                  at java.lang.reflect.Method.invoke(Method.java:585)
                  at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
                  at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
                  at org.eclipse.core.launcher.Main.run(Main.java:973)
                  at org.eclipse.core.launcher.Main.main(Main.java:948)

                  So does Flex not work with JDK 6? because if not that would explain the problem.
                  • 6. Flex won't start
                    jared_pariah Level 1
                    So here one other piece of information that may be helpful, I double-clicked on Flex Builder/Contets/MacOS/FlexBuilder. and Flex opened normally. Maybe this will be helpful to someone.
                    • 7. Re: Flex won't start
                      levancho Level 3
                      simple solution
                      download another JVM(JDK) install it anywhere you want and tell flex builder to use that JVM , thats it. most likely problem will be solved
                      • 8. Flex won't start
                        jared_pariah Level 1
                        That seems like it would work. But how can I have Flex point to the new JDK if I can't open Flex?

                        By the way I have already changed the Java path variable so that it points to a stable JDK and I reinstalled the Xcode tools just to see if that might help.