6 Replies Latest reply on Jan 6, 2010 8:13 AM by wadedwalker

    Can't run project because of error in code

    disguy

      I was working on a project and started creating a scroll panel per the instructions at http://forums.adobe.com/message/2295900#2295900

       

      After creating the scroll panel, I tried running the project and it told me I couldn't run it because of a code error.  Looking at the problems panel, I got an error that said "Open quote is expected for attribute "id"." I wanted to work backward to see what was causing the problem and reverted the panel back to artwork and got the same error in the line for my scroll bar, so I reverted that and got it for my track shape, and reverted that (it had reverted to a button earlier, not sure why), and I got the error for my thumb, so I reverted that (a button again), ran the project and got the error for the text I was using as scrolling content, etc....

       

      It seems like I'm getting this error everywhere with all the elements I need for my scroll panel, and it seems to be moving from element to element.  I'm not a coder so I'm wary of getting in there and changing  things.  What could be the problem?

       

      I can't seem to attach my project because it is too big (5.2 MB) and zipping it doesn't reduce it's size.

       

      Any help would be greatly appreciated!

       

      -Ryan

        • 1. Re: Can't run project because of error in code
          acath Level 4

          Hi Ryan,

           

          It sounds like you've hit a bug in Catalyst. I haven't heard of that one, so let's try to get to the bottom of it.

           

          Can you either:

           

          1.  Send me exact steps to recreate the problem starting with an empty project, or

          2.  Send me your project? My email is adamcath at adobe dot com.

           

          -Adam

          • 2. Re: Can't run project because of error in code
            disguy Level 1

            Okay, I'll work on creating the steps, but as is, my current project after saving and closing won't open any longer.  FC says its invalid.

            • 3. Re: Can't run project because of error in code
              disguy Level 1

              I created a new project and went through the same steps that led to my bug; however I wasn't able to recreate the bug.  Here is the project anyway, and here are the step i took:

               

              import an swf into the project, (it's a looping video)

              created text, using text tool.

              drew a line, using the line drawing tool

              -changed the weight

              -made it gradient

              -tweaked the gradient colors

              Imported a .psd file of thumb, moved it over the line i drew for the track

              converted the line and thumb into a vertical scroll bar

              -assigned parts (line to track, thumb to thumb)

              imported a .psd image that's called whitefeather, to act as a top and bottom border

               

              project running

               

              -converted scroll bar, text, and border to scroll panel

              -Assigned the text as the scrolling content

              -tweaked the scrolling content are, made it a little bigger

               

              ran project.

              • 4. Re: Can't run project because of error in code
                disguy Level 1

                I tried to open up an older version of the project and it came up invalid as well, might have saved it when I was into the bug, but I got this message after if told me the project was invalid

                 

                Error invoking Java command

                (IncomingCommandHandller): toolTipShown

                 

                org.eclipse.swt.SWTError

                 

                and for details it says

                 

                Error invoking Java command (IncomingCommandHandller):

                No more handles

                 

                Are these invalid projects goners?

                • 5. Re: Can't run project because of error in code
                  acath Level 4

                  Hi Ryan,

                   

                  Can you email me the project that DOES have the error?

                   

                  Thanks,

                  -Adam

                  • 6. Re: Can't run project because of error in code
                    wadedwalker Level 3

                    I think I remember coming across the same error(the quotation id one) before a month or two back and I think it was because of me having a Component library name and a State with the same name when that component was in that State.