2 Replies Latest reply on Jan 6, 2010 12:34 PM by dmhuffman

    Audio Swap Channels not working

    dmhuffman Level 1

      I'm running Premiere Pro CS4 on a Dell XPS that was recently upgraded to 64bit.  I have 8GB memory, Intel Core 2 Quad CPU Q660 @ 2.40 GHz. My sound card went bad so I'm only using the sound device that came with the computer.  The device manager says a High Def Audio Device (internal HD audio BUS) is the sound device being used.  No other name is given.


      The audio file I am working with shows this in Properties :Source Audio Format: 48000 Hz - 16 bit - Stereo; Project Audio Format: 48000 Hz - 32 bit floating point - Stereo


      Question:  I've never had a problem adding a second line of audio, going to Audio, Stereo, Swap Channels.  This time, the audio won't swap channels.  I've tried it several times, closing Premiere, rebooting, it still isn't working.


      Is this a sound card problem or something else?  I stupidly told IT I don't need another sound card as long as I can hear it.  I'm thinking I made a mistake.  Any ideas?



        • 1. Re: Audio Swap Channels not working
          Level 4



          I don't do any sound stuff in Premiere and have only Premiere CS3...  but I have been doing some sound outside of Premiere and have been reading up on using Premiere for doing some sound editing.  Does this portion of the help file on mapping sound do you any good ?  The bold I put there to more or less ask if you have that enabled or not since you might have different setting since upgrading to 64 bit ??



          Map audio channels

          You can define how a clip’s audio is mapped to channels, audio tracks, or  both when the clip is added to a sequence or viewed in the Source Monitor. You  can determine how different types of clips are mapped, by default, by setting  Audio Output Mapping preferences. Mapping is applied to clips in the Project  panel using the Source Channel Mappings command. You can simultaneously apply  the command to multiple master clips. When the command is applied, the following  controls are available in the Source Channel Mappings dialog box:

          Track Format
          Defines the type of track in which the clip’s audio channels are  grouped—mono, stereo, mono as stereo, or 5.1 surround. When you change a master  clip’s track format from stereo or 5.1 surround to mono, Adobe Premiere Pro maps  each channel to a separate mono track. When you add the clip to the sequence,  the clips on the separate mono tracks are linked together. For more information  on multi‑clip links, see Linking multiple audio  clips.
          Enables or disables an audio source channel. When you add a clip to a  sequence, only the enabled channels are added to the Timeline panel. Disabling a  source channel also prevents you from swapping its output channel with another  source channel.
          Source Channel
          Lists the original channels of the clip’s audio.
          Displays the order that the channels are placed into the Timeline panel.
          Note: Under Track, the numbers  don’t correlate with the actual audio track numbers.
          Displays the channel type that the source channel is mapped to.
          Playback button and slider
          Lets you preview the audio of the selected source channel. You can preview a  source channel whether it’s enabled or not. The playback button and slider is  unavailable if you’re applying the Source Channel Mappings command to multiple  master clips.

          You should map source audio channels before adding a clip to a sequence. If  you apply the Source Channel Mappings command to a master clip that’s been added  to a sequence, you can swap only the output tracks and channels between source  channels. The Track Format and Enable controls are unavailable, preventing the  master clip’s overall configuration from becoming out of sync with instances of  the master clip already in a sequence.




          • 2. Re: Audio Swap Channels not working
            dmhuffman Level 1

            Thank you!  There were two selections under Audio Output Mapping preferences.  One was Stereo and one was Digital.  The only one checked was Digital, so I unchecked that and checked Stereo and it worked.  Was probably changed somewhere along the line when they did the upgrade.


            Thank you again for sharing this information and getting me back on track!