2 Replies Latest reply on Feb 15, 2011 10:42 AM by CannotCompute

    Cannot resolve schema definition

    amthekkel Level 1
      Hi,
      i am trying to connect to a wsdl file that contains a list of operations, some for reading data and some for writing data into a database. To write to a database i need to use a submitWorkflow method. i need to pass the usual database name, username password, the workflow id, the schema and the diffgram packet which contains the new data to be inserted.
      i have tried this method with java using http service and it worked fine. I tried it with Flex and i kept getting errors due to cross domain scripting.
      I changed access to using webservice and i was able to get data in the database using the get methods in the wsdl.
      When i tried to access the submitworkflow method and pass the required parameters i get the following error.
      Any suggestions??
      [FaultEvent fault=[RPC Fault faultString="Cannot resolve element definition for ref ' http://www.w3.org/2001/XMLSchema::schema'" faultCode="EncodingError" faultDetail="null"] messageId=null type="fault" bubbles=false cancelable=true eventPhase=2]

      cheers,
      abhi