4 Replies Latest reply on Jan 7, 2010 1:10 PM by Peter deHaan

    Bug in beta2 flash builder RichEditableText

    littlebighorn5

      Ok,

       

      Some may argue this is not a bug; but I beg to differ...

       

      <s:RichEditableText id="info15"

      text=""

      fontFamily="Andalus Regular"

      editable="false"

      fontSize="24"

      x="100"

      y="100"

      minHeight="150"

      minWidth="900"

      width="900"

      textAlign="center"/>

       

      Enter this statement on a page and forget the "width" parameter, it will compile without any complaints and apparently run only... your flash page will never finish loading... it goes into deep cyberspace, and doesn't come back.

       

      Mark

        • 1. Re: Bug in beta2 flash builder RichEditableText
          Peter deHaan Level 4

          littlebig,

           

          Can you please file a bug at http://bugs.adobe.com/flex/ and include your test case and we can take a look.

           

          Thanks,

          Peter

          • 2. Re: Bug in beta2 flash builder RichEditableText
            Peter deHaan Level 4

            Actually, it looks like this was already fixed in the latest builds... I tried the following code with Flex SDK 4.0.0.13286 and it displayed the text fine:

             

            <?xml version="1.0" encoding="utf-8"?>
            <s:Application xmlns:fx="http://ns.adobe.com/mxml/2009"
                    xmlns:s="library://ns.adobe.com/flex/spark">
                <s:controlBarContent>
                    <s:Label id="sdkVer" initialize="sdkVer.text = mx_internal::VERSION;" />
                </s:controlBarContent>
               
                <s:RichEditableText id="info15"
                        text="The quick brown fox jumps over the lazy dog."
                        fontFamily="Andalus Regular"
                        editable="false"
                        fontSize="24"
                        x="100" y="100"
                        minHeight="150" minWidth="900"
                        width="900"
                        textAlign="center"/>

               

            </s:Application>

             

            Peter

            1 person found this helpful
            • 3. Re: Bug in beta2 flash builder RichEditableText
              littlebighorn5 Level 1

              Peter,

               

              I am sorry I wasn't clear enough. This does not work, remove the "width" and it will not complain, it will hang, will report it in the bugs URL as you suggested.

               

              <?xml version="1.0" encoding="utf-8"?>

              <s:Application xmlns:fx="http://ns.adobe.com/mxml/2009"

                 xmlns:s="library://ns.adobe.com/flex/spark"

                 xmlns:mx="library://ns.adobe.com/flex/halo" minWidth="1024" minHeight="768">

              <fx:Declarations>

              <!-- Place non-visual elements (e.g., services, value objects) here -->

              </fx:Declarations>

              <s:controlBarContent>

                       <s:Label id="sdkVer" initialize="sdkVer.text = mx_internal::VERSION;" />

                   </s:controlBarContent>

               

                   <s:RichEditableText id="info15"

                             text="The quick brown fox jumps over the lazy dog."

                fontFamily="Andalus Regular"

                             editable="false"

                             fontSize="24"

                             x="100" y="100"

                             minHeight="150" minWidth="900"

                             textAlign="center"/>

              </s:Application>

              • 4. Re: Bug in beta2 flash builder RichEditableText
                Peter deHaan Level 4

                This works fine for me in 4.0.0.13316:

                 

                <?xml version="1.0" encoding="utf-8"?>
                <s:Application xmlns:fx="http://ns.adobe.com/mxml/2009"
                               xmlns:s="library://ns.adobe.com/flex/spark"
                               xmlns:mx="library://ns.adobe.com/flex/halo"
                               minWidth="1024" minHeight="768">
                    <s:controlBarContent>
                        <s:Label id="sdkVer" initialize="sdkVer.text = mx_internal::VERSION;" />
                    </s:controlBarContent>
                    
                    <s:RichEditableText id="info15"
                                        text="The quick brown fox jumps over the lazy dog."
                                        fontFamily="Andalus Regular"
                                        editable="false"
                                        fontSize="24"
                                        x="100" y="100"
                                        minHeight="150" minWidth="900"
                                        textAlign="center"/>
                    
                </s:Application>
                 
                

                 

                Which SDK build are you currently using? You may want to try downloading a newer nightly Flex SDK build from http://opensource.adobe.com/wiki/display/flexsdk/Download+Flex+4 (ie: Flex 4.0.0.013323) and see if that fixes it for you.

                 

                Peter