1 Reply Latest reply on Jan 6, 2010 8:08 PM by carl schooff

    swf in a webapp not rendering

    FlashJay1092

      Hi all,

      I'm fairly new to Flash.

       

      I used FalshDevelop to compile PanoSalado opensource ".as" files to produce corresponding ".swf" files.

       

      When I run the file from the browser (in FF) like so:

      file:///D:/projects/xxx/earthSearch/target/earthSearch/maps/ModuleLoader.swf

       

      it works great and my movie shows.

       

      However, when I run it via a webapp under Tomcat, it just sits there. The url is:

      http://localhost:8080/earthSearch/maps/ModuleLoader.swf

       

      Note that I'm running the same file (.swf) from the same place in the filesystem.

       

       

      And I even tried to embed the swf in an html page (actually a jsp page) to see if it would work.. but no dice... same issue.

      FWIW the html that is used to invoke the swf is :

       

      <div id="flashbanner">this will be replaced by the SWF.</div>


      <script type="text/javascript">
        alert('0');
        var so = new SWFObject('maps/ModuleLoader.swf','mpl','555','416','9', '#336699');
        alert('1');
        so.write('flashbanner');
        alert('2');
      </script>

       

      So why does it do that and is there a way to debug this in a browser?

       

      Is there an example of invoking a swf in a webapp somewhere?

       

       

      Thanks a lot!

       

      Jay