9 Replies Latest reply on Jul 9, 2007 1:19 AM by YasmineFatima

    problem with hyperlink

      Hello Dear Robohelpers

      I have a problem, please advise. I cannot put a hyperlink (which is connected to the website) into my help project. I mean I know how to create a hyperlink for WWW, the problem is that the link cannot be used in the compiled HLP file. It will be a blue-highlighted text but with no reaction on mouse cursor...
        • 1. Re: problem with hyperlink
          RoboWizard Level 4
          Hi IncaDeCuzco and welcome to our community

          It would help us a lot if you could advise:

          1. What type of help are you creating? (WinHelp, WebHelp, FlashHelp, compiled .CHM, etc)
          (I did note that you said HLP file, but I also know that often folks will cite something different out of habit. By default, I think links in HLP files are green, hence the question.)
          2. I'm assuming that by saying "no reaction on mouse cursor", that the cursor doesn't change? Or are you instead saying there is no reaction when the link is clicked?
          3. Where is the help when you are seeing the issue? Are you running it from your help development PC? Or does it only happen to your end user? And where is your end user running it? From their local PC, a network resource or a web resource?

          Cheers... Rick
          • 2. Re: problem with hyperlink
            IncaDeCuzco Level 1
            Hi Rick and thanks for the reply

            1. I am working with winhelp project. Output help file is in HLP format.
            The color of hyperlink is blue. It's active while being in doc format (mouse cursor will become a palm and if you click on the text, the link will connect you to the www).
            2. For some reason, after compiling the hylerlink will stay blue-highlighted but with no reaction of mouse cursor (Cursor will not change into palm after you move it on the text ).
            3. All operations with HELP project I do on my own PC. The problem occurs on all PC where this HELP installed.

            Any ideas? Thanks again for help.

            • 3. Re: problem with hyperlink
              Hi Rick and Victor,

              I am having the exact same problem, Victor. I am trying to insert an html link into my WinHelp2000 file and it's not working. When I create the link as the way you described, it turns into blue text with no mouse action when compiled.

              However, when I create the link as a "hot spot" image, it creates the link but only opens the link in the same window as the help. Instead, I want it to open in a new browser. When i prompt it to open in a new browser, i get the following error message:

              An error exists in this Help file. Contact your application vendor for an updated Help file. (1024)

              Rick, would you be able to help out on this one? Thanks a lot in advance.

              • 4. Re: problem with hyperlink
                IncaDeCuzco Level 1
                Hi Yasmine I l t n ;)
                Done! Thanks for your hint with "hot spot" text. ;)

                Choose 'New Macro Hot Sot' from the menu > Type a text in the field provided > Choose 'Jump to HTML' in the 'type of operation' dialog then input URL address
                in the 'URL/File' field. Then choose 'show in browser' in the field below. Click OK and... voila ;) If you still have that 1024 error, it may something to do with spaces. I often have this annoying message after creating a new topic in the existing project. Pay attention to titles (its appearance in doc file and index dialog...)

                good luck ;)
                • 5. Re: problem with hyperlink
                  YasmineFatima Level 1
                  Hi Victor :)

                  Im glad it worked out for you! I tried the steps you mentioned, but im still getting that annoying error. What version of robohelp are you using?

                  thank :)

                  • 6. Re: problem with hyperlink
                    IncaDeCuzco Level 1

                    I am using "Robohelp for Word X3" (Japanese version). I work with Japanese texts... sometimes Robohelp doesnt' like it at all ;)) What is your version?

                    • 7. Re: problem with hyperlink
                      YasmineFatima Level 1
                      Hi Victor,

                      I am using RoboHelp X5 Pro. Yeah it really seems its not liking the "opening the link in a new browser" thing. I'm still trying to fix the problem!

                      • 8. Re: problem with hyperlink
                        IncaDeCuzco Level 1
                        Hi Yasmine,

                        There certainly must be a feature to "open the link in a new browser". If it doesn't work, there is a high probability of some kind of a bug.. Some residents of this forum might probably know how to fix it... I hope you'll find a solution.


                        • 9. Re: problem with hyperlink
                          YasmineFatima Level 1

                          Yeah there definitly is an option to open link in new browser. I am selecting that option, but when I click the 1024 error keeps appearing. Thank for all your help.