8 Replies Latest reply on Jan 15, 2010 9:49 AM by _nat

    Tracking bug in AE CS4?

    _nat

      I've been using the motion tracker a lot lately, and I've recently been having a problem. I believe this started when I updated AE to 9.0.2, so I think it might be a bug in the new version. (Not long before, I upgraded from CS3 to CS4, so it might be a problem with CS4 in general.)

       

      Here's a description of the problem. I add motion to some footage via a null object (linked with expressions, not parenting), pre-comp them together, then try motion tracking the new composition. While tracking, the track points seem to follow the footage just fine, but when I apply the data, or even scrub through to adjust the track points, they're completely off; it's like they were tracking different footage altogether (perhaps the original footage in the other composition?). This doesn't always happen, but it's happening most of the time, and it's becoming a source of great frustration.  Is there something I'm overlooking that could be causing this problem, or is there a bug when tracking nested compositions? (I don't have the problem when tracking normal footage; so far, it's only some compositions.) I don't think I've ever had this problem is CS3.

        • 1. Re: Tracking bug in AE CS4?
          Adolfo Rozenfeld Adobe Employee

          It's hard to say without looking at it. It can be a number of things.

          Is there any way in which you could make a very simple project, with a single, short footage item in it, to demonstrate this that you could then upload for me to check?

          • 2. Re: Tracking bug in AE CS4?
            Mylenium Most Valuable Participant

            How do you add the motion? If random elements via expressions are involved, there may be something up with the underlying random seed.... At any rate, the question to me would be why you track at all? If you create the motion all yourself, it should be perfectly possible to get all offsets by other expressions.

             

            Mylenium

            • 3. Re: Tracking bug in AE CS4?
              _nat Level 1

              Mylenium, the motion is just keyframed transformation data in the null object, usually copied from a path. In some projects, the transformation data in the null object comes from motion tracking the footage. (I track the original footage, apply the data to the null, link the footage to the null, and precompose the whole thing, then try to track that composition.) The expressions that link the footage to the null object just use simple arithmetic, no special wiggle or random functions.

               

              I realize there are cleaner ways to get the data, but this method produces the exact rough effect I need for several of my projects, where expressions just don't cut it.

              • 4. Re: Tracking bug in AE CS4?
                _nat Level 1

                Adolfo, I'll try to reproduce the problem in a small project file and send it to you so you can have a look.

                • 5. Re: Tracking bug in AE CS4?
                  yenaphe Level 4

                  If you create a comp, add a white solid comp size, add a black solid something like 25px square, add a wiggle() expression on it position / rotation, precompose and track the precomp, do you have a correct result or do you have the same problem ?

                  • 6. Re: Tracking bug in AE CS4?
                    _nat Level 1

                    Sébastien, I did not have a problem when trying what you suggested. I even used the same expressions to link the solid to the null object, but it worked fine.

                    • 7. Re: Tracking bug in AE CS4?
                      Mylenium Most Valuable Participant

                      Are your nested items parented in some way? Do they have distortion effects of some kind that may offset the pixel content? Are there any 3D or adjustment layers involved? Anything imported from Photoshop? In the latter two cases, a number of long-standing issues have been fixed that may result in different behaviors.

                       

                      Mylenium

                      • 8. Re: Tracking bug in AE CS4?
                        _nat Level 1

                        Mylenium, none of the items are parented, and there are no effects, adjustment layers, 3D layers, cameras, lights, Photoshop layers, or anything of that nature. Right now, I just have a composition ("Comp A") containing a second composition ("Comp B") which itself contains only one layer of footage and one null object. In Comp B, I tracked the motion of the footage and applied it to the null object, then used expressions to link the anchor point and rotation of the footage layer to the position and rotation of the null object (respectively). Comp B is in Comp A by itself or with an empty null object. No effects or expressions are used in Comp A. While in Comp A, I try to motion track Comp B, but that's when the problem arises.

                         


                        I played around with the problem some more this morning, and here's what I have.

                         

                        I tried rendering the precomposition and tracking it as footage instead of tracking the precomp as a composition, and it worked. I then precomposed the rendered footage, tracked that, and it still worked. I was using the exact same tracker (copy and pasted from one to the other), and it produced different results. Later, I'm going to try to convert the expressions to keyframes, so all transformation data is contained within the footage layer, and there is no null object. I'll also try replacing the footage drectly with a solid. I'll post my results.

                         

                        I just read the other threads regarding the problems caused by Wacom drivers. I recently installed a Wacom Intuous 4 on my machine, so I thought I would try disabling the driver to see if it made a difference. So far, there doesn't seem to be any difference with my problem, but I'll keep experimenting until I'm sure.

                         

                        I've been noticing that sometimes the tracking points seem to snap back to the footage after about half-way through. So at the beggining, they're completely off and bouncing around, but then they suddenly start following the footage correctly. Perhaps the tracking data is getting lost or corrupted past a certain point?

                         

                        Thanks for all of the input so far, everyone. I'll post more info when I have it.