2 Replies Latest reply on Jan 20, 2010 5:08 AM by M_Bakker

    Problem launching Air 1.5 app in Windows 7

    RickSaada

      I've got an internal tool that is written in Flex/Air and distributed to our content designers for producing game content.  It's been working great until we started getting Windows 7 machines in the office.  On some of these machines, after installing Flash/Air and our tool (TerrainEdit), TerrainEdit will just fail to launch.  Everything claims it installed fine, a process gets started (which I can see in Task Manager), but as far as I can tell my code never gets called.  I've tried putting a log file write in the init function and it never happens.  Since I'm an Air app it doesn't write to the flash log.   The first time this occured I managed through some combination of uninstalls of air, reinstalls of air, reboots of the machine, etc to have it just start working.  So I wrote it off as a Windows 7 fluke.  But now it's happening again, and I can't seem to make it work.  I've tried clean installs of flash, air,  and TerrainEdit, and I'm getting exactly the same result.  A process spins up, but it never gets to me.  Anyone else seen something like this?  Have a magic incantation I can try to make it work?  I'm worried this will become an ongoing hassle as more new machines with Windows 7 appear in house.

       

      Thanks,

       

      Rick

        • 1. Re: Problem launching Air 1.5 app in Windows 7
          RickSaada Level 1

          So I made some progress on this, which might point to the answer.  It appears that installing my app in Program Files x86 is the issue.  If

          I try to install in Program Files it redirects to x86, and continues to fail.  If however, I install in a completely different directory, say c:\tmp\TerrainEdit, then it runs just fine.  So I suspect there's some funky permissions problem between air and Windows 7 with running out of the holy thou shall not touch Program Files directory, but it works fine elsewhere.

          • 2. Re: Problem launching Air 1.5 app in Windows 7
            M_Bakker Level 1

            I can confirm this issue. I had the same thing when using the AFCS SDK Navigator. As with you, my solution was installing to a different directory.

            Glad to see that I'm not the only one messing around with this, hehe.

             

            Michiel