5 Replies Latest reply on Jan 25, 2010 6:50 AM by Anshulg

    PHP service on https (ssl), but requests are being made to http

    Jadware

      XAMPP Lite installed on local machine with https enabled and working great.  PHP backend service is installed in root htdocs.  Project's web root is configured to c:\xampplite\htdocs and https://localhost/.  But when debugging my Flex 4 app with Network Monitor, I see all the AMF traffic going over http.  Also, if I turn off port 80 on the web server, the app fails with the complaint that http://localhost/app/gateway.php was not found.  Server root is set to https://localhost though, not http.  I've checked in the project properties file and even in the .model/xx.fml, and everything says https.  Is there another setting, or is this a bug?

       

      In general, is there any way to pass amf traffic to php over a secure connection?