10 Replies Latest reply on Feb 18, 2010 8:21 AM by krumlin

    constant crashes: Unable to allocate space for image buffer

    krumlin Level 1

      I've been working on this crash for MONTHS.  I use a big image now and then by necessity for my animations. I get these constant crashes (see image attached)

       

      I've upgraded to CS4 and through trial and error in the preferences was able to stop the crashes (see attached image).  I've had this issue on 3 computers now and it's obviously an inherent problem with After Effects.

       

      So now the rest of After Effects is pretty messed up... I get 10 minute delays before and after every render for example.  But I have to just deal with it to avoid crashing.

       

      Can anyone tell me the proper preference settings for a Mac Pro?

      2x2.26 GHz Quad-Core Intel Xeon

      8GB memory (4x2GBs)

      ATI Radeon HD 4870

      Snow Leopard


      Seems to me the computer is powerful enough, how can I set preferences so that it runs smoothly?

        • 1. Re: constant crashes: Unable to allocate space for image buffer
          Mylenium Most Valuable Participant

          Turn off multiprocessing!!!!!! I mean, you are garotting AE. You already have way too little RAM for the many cores in your machine. If you would want to use MP on a dual Xeon Mac Pro and want to satisfy the 2GB per core recommendation (as explained in the help), you need at least 16 GB and even that isn't true, as your OS and everything else still need RAM, too. Sorry to be so direct, but attempting to work with an image at the size you mentioned with perhaps about 0.5GB effective RAM avaialbel per core is never gonna work, even more so as the actual processing of the image with effects may consume even more RAM. Do the only sensible thing: turn MP off until the day you have more RAM in your machine.

           

          Mylenium

          1 person found this helpful
          • 2. Re: constant crashes: Unable to allocate space for image buffer
            Adolfo Rozenfeld Adobe Employee

            Alternatively, you can set AE to use less cores for rendering (and thus give more RAM to the remaining cores). You can do this by leaving a number of cores free in the Memory and Multiprocessing preferences. With 8 GB o RAM and large source images, you may want to use 3 cores and leave 5 cores out (or, of course, get more RAM as suggested).

            That said, given an unusually large footage item, you can still run out of memory with Multiprocessing off (because of the ceiling imposed to 32 bit processes). This is why Adobe's recent announcement that the next version of AE will be fully 64-bit is so important.

            1 person found this helpful
            • 4. Re: constant crashes: Unable to allocate space for image buffer
              krumlin Level 1

              Thanks for all the input, I've researched those links.  I see why I should not be using multiprocessing, but as soon as I turned that off these errors came back!  With multiprocessing on at least I don't get any errors.

              So I need to buy more RAM and I currently have 8GBs (4x2GBs) can I fill the other four slots with 4GBs eachor do they need to be 2GBs to be consistent?  I was told that all the slots need the same RAM.

              • 5. Re: constant crashes: Unable to allocate space for image buffer
                ChrisProsser Adobe Employee

                How big is your big image?

                 

                This is a great page, sounds like you may need to do Step 4 for your big image: http://generalspecialist.com/2006/11/avoiding-after-effects-error-could-not.asp

                 

                If you turn off MP, try setting your RAM for other applications to something like 6GB. This is the equivelent of step 3 in his directions above.

                 

                --c

                • 6. Re: constant crashes: Unable to allocate space for image buffer
                  krumlin Level 1

                  I've seen that before, it suggests breaking your huge image into chunks, and reassembling them in AE.  I don't really see how I can do that other than by eye.  If there were an auto way of putting the pieces in place in AE I'd try, but I'm not moving those pieces around one by one like a huge digital puzzle.

                   

                  That article starts by saying you can use big images no problem in other compositing programs even on older machines, but it doesn't work in AE.  I suspect AE is not the program for me if that is true, because I am trying to make animations and usually the background elements just need to be large.

                  • 7. Re: constant crashes: Unable to allocate space for image buffer
                    Andrew Yoole MVP & Adobe Community Professional

                    To divide your image into chunks, simply cut it into segmented layers in Photoshop, then import the PSD into AE as a comp (cropped layers).  Don't precompose the layers or you'll defeat the purpose - the individual segments should be in your main comp.  I often try to limit segmented images to 1000x1000 pixel layers.

                     

                    Applying filters (especially blurs), shadows or depth of field to large images increases the amount of memory they consume, so be wary of that also.

                    • 8. Re: constant crashes: Unable to allocate space for image buffer
                      krumlin Level 1

                      OK so just to recap: I get crashes with multi-processing off.  When multiprocessing is on I can work, but it's quite slow and there are long delays before and after renders -where AE pretty much freezes up for 5-10minutes.

                      I just got 16GB of RAM, since AE recommends that as a minimum to use multiprocessing, but it seems even worse now.  Rendering is twice as long and I still get long delays.  What could be causing this?  My Mac at home has 8gb of RAM and runs a little smoother with the same preference settings.  It's as if AE is getting slower and slower on the 16GB machine??

                      (Please see the original post for my preference settings)

                      • 9. Re: constant crashes: Unable to allocate space for image buffer
                        ChrisProsser Adobe Employee

                        Hi Krumlin,

                         

                        I think I need to know a lot more about the project you are trying to render to help any further. One of the reasons we are doing a 64 bit port is specifically to help situations like yours where you have many large images.

                         

                        I just want to clarify how you are using the term 'crash'. Do you mean you get the Unable to allocate error dialog? Or does the application cease working and present you with a dialog to send information to Apple?

                         

                        This may sound counterintuitive, but can you try the following experiment:

                        1) Uncheck Render Multiple frame Simultaneously

                        2) Change RAM to leave for other applications to 15GB (which will only allow AE to use 1GB in the main process).

                         

                        If you do turn MP back on, make sure to increase the "RAM to leave for other applications" to 3GB now that you have 16GB of RAM. We've noticed that the operating system really needs this kind of space when you have 16GB of RAM and the After Effects defaults are not great.

                         

                        This will shorten your ram previews but if you are suffering from fragmentation (arcane technical term) this will help and mimics what happens when you have MP turned on.

                         

                        --chris

                        • 10. Re: constant crashes: Unable to allocate space for image buffer
                          krumlin Level 1

                          Chris:

                          The problem was not technically a "crash" I just got the "unable to allocate for 5350x1900 (for example) pixels, you may experience fragmentation etc..." error -which would halt my renders.  The project is contains 1080p comps with cameras panning across layered psd files for depth.

                           

                          The ONLY way I've gotten AE to work for me consistently was by turning on multiprocessing with the settings in the original post.

                          This causes a new problem, when I render the program freezes up and gives me the spinning ball icon for 5 to 10 minutes before it even starts rendering.  The other problem is that once and a while a 45 minute render will decide to take 20 hours till I cancel it.  If I don't cancel it that number keeps going up and never ends.

                           

                          I understand that you need at least 16gb of RAM to use multiprocessing so I bought it.  But things have gotten worse not better.  Now it delays 10 to 30 minutes before renders!

                          I tried increase the "RAM to leave for other applications" to 3GB, and left some renders overnight at work.  after rendering a few videos for a total of 4 hours, it just stopped and is still hanging through the next day with the spinning ball.

                           

                          The problem with experimenting with settings is that most work at first, but when it comes time to render overnight it'll fail.  For now I just need to get these renders done right away.  Do you have any other ideas?  Maybe Open GL instead of multiprocessing?  I don't want to randomly change things for my renders to fail overnight, but I don't know what in the preferences will help AE "allocate" beyond what I've already done.