2 Replies Latest reply on Sep 5, 2007 6:49 AM by hans blix

    Problem with JVM args

    hans blix Level 1
      We are trying to debug some issues with our ColdFusion installation and decided to revert our JVM settings back to their original state. According to a technote, these are the settings we should use:

      technote: http://kb.adobe.com/selfservice/viewContent.do?externalId=ce138b7a&sliceId=1

      java.args=-server -DJINTEGRA_NATIVE_MODE -DJINTEGRA_PREFETCH_ENUMS -Xmx1024m -Dsun.io.useCanonCaches=false -XX:MaxPermSize=512m -Dcoldfusion.rootDir={application.home}/../ -Dcoldfusion.libPath={application.home}/../lib -XX:+UseParallelGC -Dcoldfusion.classPath={application.home}/../lib/updates,{application.home}/../lib/,{appl ication.home}/../gateway/lib/,{application.home}/../wwwroot/WEB-INF/cfform/jars

      The problem is that CF won't start with these settings. I found that if I removed the MaxPermSize setting, CF would start with no problem.

      Since our original issue was memory related, I'd like to know why the server would not start with the MaxPermSize setting in place. Is this a deprecated setting? Any help would be appreciated.

      Environment:
      CF7.0.2
      Win2K Server
      JVM: 1.4.2_15
        • 1. Re: Problem with JVM args
          Grizzly9279 Level 1
          Ours is set to "128m" - which is the default for CFMX 7.0.2 I believe.

          Was 512m too large for your environment perhaps?
          I would try adding the setting back into the JVM args, and changing it to 128m to see if that works.

          Also, be very aware of extra newline or whitespace characters in your JVM arg list. It is easy to get confused if you're editing the args via the <textarea> provided by the JRun console. I personally prefer to manually edit the jvm.config file, located here:
          .....\JRun4\bin\jvm.config
          • 2. Re: Problem with JVM args
            hans blix Level 1
            That did the trick, thanks.