2 Replies Latest reply on Feb 1, 2010 8:29 AM by mmorse22

    CS4 swf code and Firefox

    mmorse22

      Having problems with CS4 flash code and Firefox. It works fine in IE7 and Safari but Firefox will only display

      "Content on this page requires a newer version of Adobe Flash Player."

      I have the latest flash plugin both on my Mac and PC yet neither will work. Anybody else have this problem?

        • 1. Re: CS4 swf code and Firefox
          vwgn

          I had the exact same problem, except the browsers were switched. I stumbled around for a while and finally did the

          logical thing, deleting all the code and swf I had copy/pasted from flash's export and inserted just the swf with dreamweaver, allowing it to write the code, and problem wa fixed. Something in flash just didnt come out right on the export or I missed a line somewhere in my copy/paste. FF was smart enough to play the swf anyway, but IE just gave me a script error/install flash... Try that and see what happens, worse case it does nothing but leave you where you are at.

          • 2. Re: CS4 swf code and Firefox
            mmorse22 Level 1

            My fix was to dump the CS4 code altogether and use the code from Google. Far

            less code and it worked for IE, FF and Safari just fine. The Google code is

            a MUCH better solution IMO.

            --

            Mark Morse

            Marketing Services

            Sanmina-SCI

            20091 Ellipse

            Foothill Ranch, CA 92610

            949-643-7255 ext 2261

             

             

             

            From: vwgn <forums@adobe.com>

            Reply-To: <clearspace-2084520474-78827-2-2555031@mail.forums.adobe.com>

            Date: Fri, 29 Jan 2010 21:31:28 -0700

            To: Mark Morse <mark.morse@sanmina-sci.com>

            Subject: CS4 swf code and Firefox

             

            I had the exact same problem, except the browsers were switched. I stumbled

            around for a while and finally did the

            logical thing, deleting all the code and swf I had copy/pasted from flash's

            export and inserted just the swf with dreamweaver, allowing it to write the

            code, and problem wa fixed. Something in flash just didnt come out right on

            the export or I missed a line somewhere in my copy/paste. FF was smart

            enough to play the swf anyway, but IE just gave me a script error/install

            flash... Try that and see what happens, worse case it does nothing but leave

            you where you are at.