8 Replies Latest reply: Apr 12, 2011 1:15 AM by pwillener RSS

    C:\Windows\system32\Macromed\Flash\Flash10d.ocx

    ccaren1 Community Member

      Can someone please, please help???

       

      I installed FP10 on Windows Vista & says it's complete (shows the "F" icon flipping around & all).  But, when I try to open C:\Windows\system32\Macromed\Flash\Flash10d.ocx in my "C Drive", I keep getting a pop up window "Error opening file for writing" in this file & wants me to abort.

       

      I would appreciate the help very much on what I should do.  Pages on websites take forever to download.

        • 1. Re: C:\Windows\system32\Macromed\Flash\Flash10d.ocx
          MS_DaveH Community Member

          This is an active x control. It is not meant to be opened.

          Slow loads may have several causes. Assuming you have good bandwidth, most other causes are related to the add-ons you allow to run in your browser. Internet Explorer 7 and 8 both include a "no add-ons mode" which is useful. My suggestion would be to attempt running in "no add-ons mode" and notice whether or not the speed improves. If so, open IE as normal, click tools and then click manage add-ons. Disable Add-ons you don't recognize and don't need or use. I personally don't use search toolbars b/c I can easily type in bing.com and then search. This is usually faster than running a bunch of add-ons anyway. After disabling the add-ons you don't recognize/want/use, look for the column that depicts load time. Anything that takes a long time to load is slowing down your browser, disable it if you can live without it. Finally, any add-ons that you chose not to disable should be updated if available. Check the site that belongs to the vendor listed in the Publisher column of the toolbar for instructions on how to update their product. Many updates require or work better if you uninstall the old version of the product first.

          If you still experience crashes and slow loading, you should consider resetting IE. After resetting IE, notice the change in speed. You can then start to install the add-ons you want, but if it slows down again, you should disable the culprit that you just installed.

           

          This is just me personally, but I prefer to run with minimal add-ons. After resetting IE, all i re-install is the latest version of my Firewall/AV suite's browsre protection, which truthfully, isn't necessary, but I've not had problems with it.

          • 2. Re: C:\Windows\system32\Macromed\Flash\Flash10d.ocx
            ccaren1 Community Member

            Thank you for your suggestion but, I may have to rephrase my question.

             

            Under the FAQ's in FP section, it states for Windows Vista users to find Window/System32/Macromed/FlashUtil10a.exe and "Run as Administrator".  But, I can't find that in my C Drive.  I only have FlashUtil10d & Flash10d.ocx & was wondering if I "Run this as Administrator" should either one of those work?  Or, how/where can I find FlashUtil10a.exe?

             

            Thanks again so much for your input.

            • 3. Re: C:\Windows\system32\Macromed\Flash\Flash10d.ocx
              MS_DaveH Community Member

              try typing/copying this into a windows explorer adress bar %systemroot%\system32\Macromed\Flash

              If you installed the Active X it should be there. If not and you try to install again, and the file is still not there, check your IE settings to see if you have Active X controls set to Disabled, and change "download signed ActiveX controls" to Prompt as well as set "run ActiveX controls and plug-ins" to Enable or Prompt.

              • 4. Re: C:\Windows\system32\Macromed\Flash\Flash10d.ocx
                eidnolb onlyone Community Member

                Hi ccaren1, You do NOT want FlashUtila.exe at all on your computer. This is an old version of Flash Player. The latest version is 10.0.42.34 and Flash10d.ocx and FlashUtil10d.ocx reflects that you have this.

                 

                 

                May I suggest to you to go to this Adobe test site: http://www.adobe.com/products/flash/about Adobe will tell you

                what version you have installed.

                 

                The FlashUtil10a.exe that you refer to in the troubleshooting article is only an example as it says there.

                 

                In your Flash folder there are only 4 files that should be there and you already have 2. In your Manage add ons, the one that is needed for Flash Player to work is Shockwave Flash Object...ActiveX Control....Flash10d.ocx and it must be enabled.

                 

                These are the files Flash Player needs installed in order to work. If after you have these installed and then have a problem viewing a website with Flash, that is another issue. If you do not have these files installed then whatever else you do is just going to add to your problems, not fix them.

                 

                Regards,

                eidnolb

                • 5. Re: C:\Windows\system32\Macromed\Flash\Flash10d.ocx
                  ccaren1 Community Member

                  I just want to sincerly thank the both of you for your assistance.  I tried both suggestions & it confirms that I have FP10 installed.  I guess my problem is another matter.

                   

                  Thanks again!

                  • 6. Re: C:\Windows\system32\Macromed\Flash\Flash10d.ocx
                    eidnolb onlyone Community Member

                    Hi ccaren1, Thanks for the feedback. If you are still having a problem after confirming you have FP installed, just post

                    back. Sometimes it is an ActiveX/BHO that conflicts in the add ons.

                     

                    You may want to make sure your Java has the latest version, which is JRE 6 update 18. You would remove any other Java listings first in the Add/Remove section. Should you need assistance with that you can just post here on this thread.

                     

                     

                     

                    eidnolb

                    • 7. Re: C:\Windows\system32\Macromed\Flash\Flash10d.ocx
                      akela184 Community Member

                      I seem to be having the same issues as ccaren... I have successfully downloaded flash but I can't get anything to play and always get messages that I must download it to view the page...  I'm running Vista/IE9 on an ACER laptop.  I've never had any problems in the past with using flash on my laptop before.  I have Enabled ActiveX - and followed all the steps in the Troubleshooting guied.  I have the following Flash items in my C:/Windows/Sys32/Macromed/Flash Folder:  Flash10o.ocx, Flash Install, FlashUtil10o_ActiveX.dll, FlashUtil100_ActiveX and an install.  Java is up-to-date as well... Any ideas?

                      Akela184

                      • 8. Re: C:\Windows\system32\Macromed\Flash\Flash10d.ocx
                        pwillener CommunityMVP

                        akela184 wrote:

                         

                        I seem to be having the same issues as ccaren...

                        You seem to have a completely different problem than the OP.  Please start a new topic with all information, and someone will help you.