8 Replies Latest reply on Feb 11, 2010 11:05 PM by Mylenium

    Rendering via backend server page and IIS

    WallStreetVH

      Hi,

       

      Using AE CS3 Ver 8, I'm attempting to run a script via a server page. I can manually run the script from a batch file and watch AE open and watch the script execute. When I call the same batch file from a backend server page, the batch file runs and I see the processes in the Task Manager, but the file is never rendered. I can accept not being able to see the progress if it indeed the file was rendered.

       

      I've tested several ways but here are the two most prevalent - one runs a script and the other renders a composition. Both work manually. However, via the web page, the AfterFX.COM process counts up Mem Usage as it does when I run it manaully, but when it gets to the same amount of memory used when invoked manually, the process remains in the Task Manager and no file is rendered. When I run the batch that renders a composition, the process actually finishes and is removed from the Task Manager but again no file is rendered. Folder/File permissions for the receiving directory have been granted  in IIS.

       

      Script:

      "C:\Program Files\Adobe\Adobe After Effects CS3\Support Files\afterfx" -r C:\Kawbox\TextScript\test_script4.jsx

       

      Rendera Comp:

      "C:\Program Files\Adobe\Adobe After Effects CS3\Support Files\aerender" -project C:\websites\Digibay\Kawbox\Webfunction\kw_test3.aep -comp "Comp 1"

       

      Thanks for your help,

      John