0 Replies Latest reply on Nov 27, 2007 6:34 PM by CoCo369

    CF 7.0.2 & Flex Builder 2

    CoCo369
      I have a local install of CFMX7.0.2 on Mac OSX as well as a Flex Builder instance running as a plugin for Eclipse 3.2 (because FB2 doesn't install with Eclipse 3.3). Now, I've been trying a demo app (very simple) that was from a tutorial on Lynda.com titled "Calling ColdFusion components as remote objects".

      I thought I finally got everything right...
      1) Made Sure I had CF 7.0.2
      2) Made Sure I had FB 2 on Eclipse as a plug-in because I heard others had issues running FB 2 stand-alone
      3) Had all my application/document paths setup to point to the actual 'localhost:8500' directory of CF
      4) Had my "Additional Compiler Arguments" setup as (-services "/Applications/ColdFusionMX7/wwwroot/WEB-INF/flex/services-config.xml" -locale en_US)
      5) Had my CFC & MXML paths setup as expected
      6) Punched my desktop, spit on my monitor and cried in my open palms

      Yet, nothing seemed to work...

      Here's what I have published as an example!

      MXML:
      <?xml version="1.0" encoding="utf-8"?>
      <mx:Application xmlns:mx=" http://www.adobe.com/2006/mxml" layout="vertical">
      <mx:RemoteObject id="cfService" destination="ColdFusion" source="flex2btb.cfc.MyService"/>
      <mx:Button label="Call ColdFusion" click="cfService.helloWorld()"/>
      <mx:Label text="{cfService.helloWorld.lastResult}" fontSize="18"/>
      </mx:Application>

      CFC:
      <cfcomponent>
      <cffunction name="helloWorld" access="remote" returntype="string">
      <cfreturn "Hello From ColdFusion">
      </cffunction>
      </cfcomponent>

      I mean really, could it get any simpler then that...really...yet somebody, somewhere is pointing and laughing because they know this isn't working!

      Please Help Me!

      Signed,
      Really f'n Frustrated!!!