1 Reply Latest reply on Mar 11, 2010 6:51 PM by wongea

    Font Problems Upgrading from LC 7.2 Forms to ES Update 1 (8.2)

    wongea

      Old Environment:  LC 7.2 Forms, Windows 2003, Weblogic 8.1 SP5, Oracle 10.2.0.4

      Old Fonts Directory:  c:\windows\fonts.  The customer fonts were also added to this directory and the fonts were embedded into the adobe-FontManager.ear.

       

      New Environment:  LC ES Update 1 (8.2) SP3, Solaris 10, WebLogic 10.0 MP2, Oracle 10.2.0.4

      New Fonts:  Copied all the adobe-FontManager.ear ttfs into the customer fonts specified directory.

       

      Problem:  I have the same XDP template being used in the old and new environment.  I have two environments (Old or New) with the code to invoke the LC Forms server.  The old environment prints out a Chinese form correctly.  The new environment prints out the Chinese form, but a lot of the text are bolded when it wasn't showing that problem before in LC 7.2 Forms.  Any thoughts on what might be cauasing this issue?

       

      Thank you for your help.

        • 1. Re: Font Problems Upgrading from LC 7.2 Forms to ES Update 1 (8.2)
          wongea Level 1

          I couldn't get a LC ES Forms server solution to this problem.  Adobe LC support stated that I had to modify the XDPs that show the bolding problem.  According to Product Engineering and Escalations group, LC ES 8.2.1 contained changes with respect to font attributes that we need to modify the XDP.  There are no server level changes that can solve the problem.

           

          Solution for me:

          1.  Open the XDP that showed the bolding problem in LC Designer ES SP3.

          2.  Find the bolded Chinese characters and unbold them.  Save the XDP.

          3.  Drop the updated XDP on to the LC ES Update 1 (8.2.1) Forms server.

          4.  Render the form in LC ES Update 1 (8.2.1).  No unwanted bolded characters for me.  As a plus I noticed the XDP size grow smaller in terms of file size after I saved it on ES Designer SP3.