3 Replies Latest reply on Jun 26, 2010 12:19 PM by P. Nijman

    Error when opening AIR Settings

    P. Nijman

      When I click the Edit button next to AIR Settings in the properties panel in Flash CS4 Version 10.0.2 I get the following error:

       

      http://grab.by/2ikY

      The following JavaScript error(s) occured:

       

      At line 984 of file "Apollo_OpenSettingDialog.jsfl":

      exportSWF: Argument number 1 is invalid.

       

      I've installed the new AIR2 (beta2) I found here: http://labs.adobe.com/downloads/air2.html,

      but I don't think this error has anything to do with it.

       

      I'm currently running Mac OS X 10.5.8.

       

      I really hope someone can help me out here.

      I'd really appreciate the efford!

        • 1. Re: Error when opening AIR Settings
          waterdad568 Level 3


          Well unfortunately that's why they call them beta's.

           

          Try here see if it helps, at worst there is a place all the way at bottom to report bugs. I just skimmed over it and saw something about versions and runtimes may not be compatable in some cases, beta 2 vs1-2 and 1.5 and 2 runtimes in CS4:

           

          http://labs.adobe.com/wiki/index.php/AIR_2:Release_Notes

          • 2. Re: Error when opening AIR Settings
            Sentientv2

            I received this same error a few days ago and was unable to resolve it, at least intentionally. I had the error and immediately started searching the web for help and came across this page.

             

            I was able to fix it, though I cannot confirm any one action I performed that fixed this. I updated my Flash debug player and removed AIR and reinstalled it with the latest public release version. I also tried quitting Flash and starting it back up. I essentially gave up and used another computer to finish my project. I shut the machine down and came back the next day and it worked!

             

            So my advice is to remove AIR, install the latest version. Also try restarting machine after you do this.

             

            Hope that helps. I wish it was more definitive but the probably is completely gone.

             

            Thanks,

            Burton

            • 3. Re: Error when opening AIR Settings
              P. Nijman Level 1

              Thank you for your answer.

              Although it seems that my problem is solved since I've upgraded to Flash CS5.

               

              Still, thanks again for letting me know.