7 Replies Latest reply on Feb 19, 2010 10:26 AM by jace1611

    windows vs mac

    gabrielaVzla Level 1

      the files i made on  a windows machine won´t publish from my mac. i managed to compress my swf (produced from a windows version) to 200k, but its still running slow. i get a white background in the beginning before the load bar appears.

       

      i´m not sure what i´m doing wrong here.

      i just got my mac back from being repaired, and i thought i would test publishing it from there, but its not working at all.

       

      here are the two files. let me know if you have better luck and what you did.

      i still haven´t tried flash builder. maybe this could be a solution???

       

      thanks in advance.

      gabriela

       

      ps- i couldn´t attach the file because its 6mb. strange because its really quite small. i will try again later.

        • 1. Re: windows vs mac
          jace1611

          I had exactly the same problem. Created a catalyst project in Windows, copied it to my mac (when I got home) and it runs, but doesn't publish. What's more it seems to fail silently so i have no idea what happened

          1 person found this helpful
          • 2. Re: windows vs mac
            gabrielaVzla Level 1

            yeah, its weird..

            • 3. Re: windows vs mac
              acath Level 4

              Can you guys post these failing projects? These sound like bugs that need to be addressed.

               

              Thanks,

              Adam

              • 4. Re: windows vs mac
                jace1611 Level 1

                Hi adam,

                 

                I can't give you my original project as it has a load of copyright protected stuff belonging to my company. However I have replicated the problem with these to simple projects.

                 

                I may be wrong, but I suspect it is something to do with the fact that Catalyst still has a full windows path in the .fxpProperties file.

                 

                In my case

                 

                <?xml version="1.0" encoding="UTF-8" standalone="no"?>

                <fxpProperties abbreviated="false" authoringTool="Catalyst" parentProject="57a706a4-65ba-42b5-b27a-37a5a5f03115" projectUUID="57a706a4-65ba-42b5-b27a-37a5a5f03115" sdkVersion="4.0.0" uuid="bcc5f7e7-6667-40cd-a978-762d13827923" version="3">

                  <projects/>

                  <src/>

                  <swc>

                    <linked location="sdkPlaceHolder" path="sdkPlaceHolder" position="0" uuid="bcc5f7e7-6667-40cd-a978-762d13827923"/>

                    <linked location="C:/Documents and Settings/cpt6jcr/Application Data/Adobe/Flash Catalyst/workspace/testForAdamCreatedInWindows/libs" path="/libs" position="1" uuid="bcc5f7e7-6667-40cd-a978-762d13827923"/>

                  </swc>

                  <misc/>

                  <theme/>

                </fxpProperties>

                if you unzip the fxp file you'll see what I mean.
                Also notice that the Publish To .swf dialog box (opening the windows project on the Mac that is) doesn't have an output directory set and none of the options are selected. However if you open the project created on the mac on the mac then this is not the case.
                Finally, I tested opening the mac project on windows and it worked.
                In summary
                mac created fxp --> windows (all works)
                windows created fxp --> mac (all works except the ability to publish to swf)
                hope that helps
                Regards
                Jace

                • 5. Re: windows vs mac
                  acath Level 4

                  That helps a ton. I'll see if I can reproduce the problem now.

                   

                  Thanks,

                  Adam

                  • 6. Re: windows vs mac
                    acath Level 4

                    Hi Jace,

                     

                    That was a known bug in Beta 2, that has been since fixed. Thanks for reporting it. I don't know of any workaround you can use for now, except to publish the project on your Win machine.

                     

                    -Adam

                    • 7. Re: windows vs mac
                      jace1611 Level 1

                      No probs - that's exactly the work around I'm using. At least you're aware of it and it's been fixed.

                       

                      Moving projects between Windows and Macs is probably a very common situation and it would have been a pain if that that bug had made it into GA.

                       

                      Regards

                       

                      Jace