5 Replies Latest reply on Feb 11, 2010 7:59 PM by toenexx

    BSOD using Multiprocessing in AE CS4 9.0.2?

    toenexx

      Hi there. Before I explain my situation here are my specs:

       

      MOTHERBOARD: Supermicro X8DAH+
      CPU: Dual Xeon E5520  = 8 procs
      MEMORY: 4GB DDR3 10600 ECC REGISTERED CRUCIAL RAM (x 6) = 24 gigs
      VIDEO CARD: Quadro FX 1800 video card
      HD(s): Intel® X25 SATA SSD 160gb (apps), Hitachi Deskstar 7K1000.C 1TB (x 4) = 4 gigs
      DVD DRIVE: Sony Optiarc 24X DVD/CD Rewritable Drive
      SOUND CARD: ASUS Xonar D2X
      WIFI CARD: ASUS PCE-N13
      FIREWIRE CARD: 2 Channel NitroAV FireWire PCI-E Card
      CASE: SC745TQ-R1200B chassis

       

      So far the performance of AE with this setup has been phenomonal. However, recently I was pressed for time and I tried rendering out a new comp that was 3 minutes long and every time I set it off to render, my system would encounter a Blue Screen of Death. This is the first I've run into the BSOD in first week I have owned this system. I definitely do not run into this problem when multiprocessing is off, and I didn't get this problem when I had it on (however, I did have shorter comps).

       

      I am still a little confused by what my settings should be in multiprocessing, but here is what they are set at:

       

      Total After Effects memory usage: 18 gigs

      RAM to leave for other applications: 6 gigs

       

      Longer RAM Preview ||-----------------------Faster Rendering (bar is slid all the way to the left)

       

      Minimum allocation per CPU: 2.8 gigs

      Actuall CPUs that will be used: 6

      CPUS to leave for other applications: 2

       

      I am not totally sure if these settings are what I should be using, so any suggestions on that would be helpful. I googled this problem on line and the specific thread I read found that the guy had a bad memory stick. I sure hope it is not that, but if it is, that would suck big time.

       

      Anyways, any thoughts on this would be greatly appreciated. Thanks.

       

      brian

        • 1. Re: BSOD using Multiprocessing in AE CS4 9.0.2?
          Todd_Kopriva Level 8

          At a glance, it seems that your memory and CPU settings are quite reasonable for using Render Multiple Frames Simultaneously multiprocessing. You're leaving plenty of RAM for other applications, and your allocation per After Effects process is high.

           

          What operating system are you using?

           

          Do you have OpenGL turned on for rendering?

           

          Does this happen with all footage types? Does this happen with RAM previews? Does this happen with all output types? Is there something else that's different between the projects and compositions that you're working with now comapred to when you weren't seeing this problem? Basically, I'm trying to isolate the factors that lead to the failure.

          • 2. Re: BSOD using Multiprocessing in AE CS4 9.0.2?
            toenexx Level 1

            I am using Windows 7 64-bit.

             

            Yes, I have OpenGL turned on in the preferences, and I have my graphics memory set to 768 mb (which is the amount my Quadro FX 1800 has). I also have the preview mode set to OpenGL - Always On, but I turn off the viewer with Caps Lock during rendering. Although I am not sure if I am using it to render? How do I check?

             

            So far, I have been only using .movs, tiffs, and jpegs.The majority of my comp is image sequences. My comp size is 1280 x 720. I also have some text for lower thirds with motion blur, but they are just being used as captions for the footage. I noticed that it BSOD's at random points on the timeline, but they are usually at the half way point. I looked at the footage around where I estimated it BSOD, and there doesn't seem to be anything abnormal. Also, I have been outputting these renders as .mov's both in animation and photo jpeg, and I have gotten the BSOD on both. I do have an audio track, but I had that in the rendered comp I did 2 days ago (which didn't have the BSOD). The only big difference between what I rendered 2 days ago and yesterday (when I got the BSOD), is the length of the comp.

             

            And no, ram previews run perfectly fine.

             

            I am not at my workstation at the moment, but I'll tinker with OpenGL, checking off image sequences on the time line, and try different export options.

             

            Thanks

             

            brian

            • 3. Re: BSOD using Multiprocessing in AE CS4 9.0.2?
              Todd_Kopriva Level 8

              OpenGL rendering is not compatible with Render Multiple Frames Simultaneously multiprocessing. (The simple explanation is that Render Multiple Frames Simultaneously multiprocessing requires multiple processors, and you only have one GPU.) So, turn OpenGL off for rendering. See "Render with OpenGL".

               

              Personally, I leave my preview mode set to OpenGL - Interactive.

               

              I don't know that OpenGL is your problem, but it's one of the leading contenders in troubleshooting like this.

              • 4. Re: BSOD using Multiprocessing in AE CS4 9.0.2?
                toenexx Level 1

                Ahhh, that might explain why I was getting BSOD, but I am not totally sure if I was rendering with OpenGL

                or not. I'll have to check.

                 

                I'll report back when I get back on my workstation.

                 

                Thanks alot.

                 

                brian

                • 5. Re: BSOD using Multiprocessing in AE CS4 9.0.2?
                  toenexx Level 1

                  So I finally got to check out my comp.

                   

                  I haven't been rendering with OpenGL at all. I've noticed two BSOD's: when I tried rendering to my desktop on my SSD, it says something about PAGEFILE dump, and when I render out the comp to my storage disks, it doesn't say anything about PAGEFILE, it just says the BSOD. I tried different audio formats and that didn't work. I turned off multiprocessing, and the comped rendered fine (but took 2x long). THe only thing I haven't tried is turning off the sequences during when it crashes, which is around the 1100 frame mark. I'll try to take a picture and maybe a iphone video of what happens.

                   

                  Thanks.