5 Replies Latest reply on Oct 3, 2007 5:52 PM by Newsgroup_User

    Fireworks changes characters?

    eflaten
      Before I insert FW image in the upper left corner the characters looks ok:

      http://www.nuna.no/fabrikken/malkladd_ok_characters.html

      After I insert FW rendered image. The nordic characters changes looking eg as a server that not serves utf-8 the right way:
      http://www.nuna.no/fabrikken/malkladd_bad_characters.html

      it is something inthe workprosess selecting the surcefile and putting the exported .gif that causes this.

      I do this hawing a image placeholder
      like this
      <img src="" alt="" width="205" height="169" id="assosiasjoner" style="background-color: #EBEBEB" />

      1: Selct the placeholder and opens FW by pressing “create” in the placeholders properties.
      (FW opens a blank doc with same dimensions as the placeholder)

      2: I open another FW doc with some stuff I want in the new one created via the placeholder in DW. I “selct all” in that doc and paste it.

      3: I save the png in source and th new exported gif in images.

      4: The page in DW has now changed all nordic characters to eg this: øæåØÆÅ

      example:ø or ;oring; changes to: √∏

      If I put the gif without pasting the FW stuff from the other png-file. The characters wont change. Version FW is 9.0
        • 1. Re: Fireworks changes characters?
          Level 7
          Very strange effect.

          On a quick inspection, the two lines which differ are:
          the blank line:
          <img src="" alt="" width="205" height="169" id="assosiasjoner"
          style="background-color: #EBEBEB" />
          <img src="images/banner_akt.JPG" alt="" width="639" height="169" />

          and the image filled line:

          <img name="assosiasjoner_ord" src="images/assosiasjoner_ord.gif"
          width="205" height="169" border="0" id="assosiasjoner_ord" alt="" />
          <img src="images/banner_akt.JPG" alt="" width="639" height="169" />

          Using the source code editor, change the one that works to the one that
          doesn't, an element at a time until it breaks.

          I don't think it has anything to do with FW, but it does appear to be an
          HTML effect.

          When I look at the page source, it has rendered the characters correctly
          in the unbroken page and wrongly in the broken page (ie it shows up in
          the source delivered from the server.)

          So start with a working page, change things one by one until it breaks,
          then you'll know what code is causing the problem.

          After that it will be necessary to find out what causes the bad code.

          DN

          eflaten wrote:
          > Before I insert FW image in the upper left corner the characters looks ok:
          >
          > http://www.nuna.no/fabrikken/malkladd_ok_characters.html
          >
          > After I insert FW rendered image. The nordic characters changes looking eg as
          > a server that not serves utf-8 the right way:
          > http://www.nuna.no/fabrikken/malkladd_bad_characters.html
          >
          > it is something inthe workprosess selecting the surcefile and putting the
          > exported .gif that causes this.
          >
          > I do this hawing a image placeholder
          > like this
          > <img src="" alt="" width="205" height="169" id="assosiasjoner"
          > style="background-color: #EBEBEB" />
          >
          > 1: Selct the placeholder and opens FW by pressing ?create? in the placeholders
          > properties.
          > (FW opens a blank doc with same dimensions as the placeholder)
          >
          > 2: I open another FW doc with some stuff I want in the new one created via the
          > placeholder in DW. I ?selct all? in that doc and paste it.
          >
          > 3: I save the png in source and th new exported gif in images.
          >
          > 4: The page in DW has now changed all nordic characters to eg this:
          > ???¶???ò?Ü?Ö
          >
          > example:ø or ;oring; changes to: ??
          >
          > If I put the gif without pasting the FW stuff from the other png-file. The
          > characters wont change. Version FW is 9.0
          >
          • 2. Re: Fireworks changes characters?
            eflaten Level 1
            Looks like FW always changes non ascii text to something unreadable when:
            1) A placeholdeimage is created in DW and edited through the edit button found on the properties window in DW.
            2) Thsi opens FW and I saves a png in sorce-folder and the gif in the images folder.
            3) When I do that DW sayes the source is changed and asks before I saves thos edits.
            4) The FW and/or DW has messed up the content.

            It gets worse. When I edit the source png and saves even more strange caracters gets written after the first ones

            on a emty page its hapes as well ending up like this:
            <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" " http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
            <html xmlns=" http://www.w3.org/1999/xhtml">
            <head>
            <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
            <title>Untitled Document</title>
            </head>

            <body><img name="test" src="images/test.gif" width="200" height="200" border="0" id="test" alt="" />


            øæåØÆÅ
            </body>
            </html>

            • 3. Re: Fireworks changes characters?
              Level 7
              We need to identify the pathology. The way I usually try is to create a
              simple web page where the problem occurs.

              The Spry stuff complicates matters, so see if you can create a simple
              HTML page with Norwegian text that works properly *in a browser* - do a
              "preview in browser", don't just look to see how DW shows things.

              Then use FW to create an image as before, and see if you can trigger the
              problem with the simplest possible page.

              You may need to add some of the parts of your problem page to trigger
              the bug, but the simpler the example you can create that shows the
              problem, the better.

              If you can recreate the problem, report it as a bug.

              In your case, building the website you're working on, I'd do things the
              simple way and avoid the problem altogether: build the PNG image in FW,
              export it as a GIF to the images folder for you web page, then insert
              the image into the page using DW, without creating a placeholder first.
              Simplest is always best :-)

              DN

              eflaten wrote:
              > Looks like FW always changes non ascii text to something unreadable when:
              > 1) A placeholdeimage is created in DW and edited through the edit button found
              > on the properties window in DW.
              > 2) Thsi opens FW and I saves a png in sorce-folder and the gif in the images
              > folder.
              > 3) When I do that DW sayes the source is changed and asks before I saves thos
              > edits.
              > 4) The FW and/or DW has messed up the content.
              >
              > It gets worse. When I edit the source png and saves even more strange
              > caracters gets written after the first ones
              >
              > on a emty page its hapes as well ending up like this:
              > <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
              > " http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
              > <html xmlns=" http://www.w3.org/1999/xhtml">
              > <head>
              > <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
              > <title>Untitled Document</title>
              > </head>
              >
              > <body><img name="test" src="images/test.gif" width="200" height="200"
              > border="0" id="test" alt="" />
              >
              >
              > ????????????
              > </body>
              > </html>
              >
              >
              >
              • 4. Fireworks changes characters?
                eflaten Level 1
                Thanks David for guiding on this. I will defintly avoid the DW->FW->DW workflow. I am shure this is a error Fireworks create. Her it is:
                http://www.nuna.no/fabrikken/before.html
                http://www.nuna.no/fabrikken/after.html


                • 5. Re: Fireworks changes characters?
                  Level 7
                  eflaten wrote:
                  > Thanks David for guiding on this. I will defintly awoiding the DW->FW->DW
                  > worflow. I will just create in FW and insert it. I am shure this is a error
                  > Fireworks create. Her it is:
                  > http://www.nuna.no/fabrikken/before.html
                  > http://www.nuna.no/fabrikken/after.html

                  Very interesting. I'm almost certain it is Dreamweaver that's doing
                  this, in conjunction with the XHTML. If you do log a bug, zip those two
                  source files and attach them to the bug report.

                  But avoiding the DW > FW > DW workflow is the quick solution.

                  DN