1 Reply Latest reply on Feb 12, 2010 1:09 AM by Bernd Alheit

    Going crazy! Objects not becoming hidden . . .

    shevaunoconnor

      I have a bunch of checkboxes and each one corresponds to a subform that becomes visible when the checkbox is either on (1) or neutral (2).  The subforms are hidden until the box is checked. But if I make a mistake while using the form in Adobe and check a box I don't need, when I uncheck it, the subform is not becoming hidden again.  

      The first part of the code works fine:


      if (eqc812.rawValue == 1|2) {

      xfa.resolveNode("EQC812").presence="visible";

      }


      The rest that I have tried don't work at all!


      else if (eqc812.rawValue == 0)  {

      xfa.resolveNode("EQC812").presence="hidden";

      }

       

      else {

      xfa.resolveNode("EQC812").presence="hidden";

      }

       

      else if (eqc812.rawValue == 0) {

      xfa.resolveNode("EQC812").display=display.hidden;

      }


      else {

      xfa.resolveNode("EQC812").display=display.hidden;

      }


       

      else if (eqc812.rawValue == 0) {

      xfa.resolveNode("EQC812").hidden=true;

      }

       


       

      else {

      xfa.resolveNode("EQC812").hidden=true;

      }

       

      As for display=display.hidden and hidden=true, if I recreated the visible part of the code with it, it made the visible part not work either. And I tried replacing "hidden" with "invisible".

      I have made other forms where the if else if statement worked fine to make things visible and hidden.  Please help me, I am SOOO frusterated!!