5 Replies Latest reply on Feb 23, 2010 2:04 PM by Nancy OShea

    links aren't working properly

    jodi77

      Good morning.  Hopefully I can explain this clearly. I've had my website for a few years and it has always worked fine. It isn't a site that I change often, so I do forget "how to do things."

       

      In September I removed one dog page and added two dog pages. I removed "Leah."  I added "Adam" and "Bella." At the time, I didn't have photo or info for "Bella" page, so I just kinda threw Adam page as sort of a placemarker. I did create a button in Photoshop that said Bella on it and placed it on the site.

       

      Yesterday I got photo and decided to make "Bella" page. Here's the result, meaning here's how the buttons work right now, which is wrong:

       

      Home = Home.  Panya=Panya.  Zafra=Zafra.  Adam=Adam.  Bella=Adam.

       

      The final few buttons work okay and take you to the proper page.

       

      If you are on Puppies page and click on Bella button, you actually will get to the Bella page.

      If you are on Future page and click on Bella button, you get a page that shouldn't even be there, named Leah.

       

      www.dinovagsd.com

       

      Of course I have done some site checks, and I pretty much don't understand what the results mean, because like I said, I kinda forget a lot of this program; not sure that I ever really "got it" to begin with, obviously.   Thanks for help.

       

      I forgot to mention,  when I'm on the Adam page and click and drag that circle to link to proper file, even after saving, it changes back. It keeps changing back to Zafra, which is the button above on the site. If I change Bella button to link to Bella file, then Adam link changes back to Zafra.

       

      Jodi

        • 1. Re: links aren't working properly
          bregent Most Valuable Participant

          You anchor tag is around both the Adam a Bella buttons. Remove the anchor and try adding the two links again. If you haven't already, you should open code view to see what's going on.

          • 2. Re: links aren't working properly
            jodi77 Level 1

            Whoa, an anchor tag.  Thank you for that.  The thing is, I have absolutely no idea what an anchor tag looks like, how to access it, and how to remove it.

             

            I really wish I new how to read code.  At my age, there's no way I'd tackle it.  As you can imagine, my dogs keep me busy (genetics- just as bad as code:) Thanks again.

             

            Jodi

            Addendum:  I'm working on trying to figure this out.  Is this something that would apply to my situation?

             

            http://kb2.adobe.com/cps/140/tn_14088.html

            • 3. Re: links aren't working properly
              Nancy OShea Adobe Community Professional & MVP

              On line 43 of your Code, you have this:

               

               <p><a href="index.html"><img src="greenhome.jpg" alt="home" width="144" height="54" vspace="2" /></a><a href="panya.html"><img src="greenpanya.jpg" alt="panya" width="144" height="54" vspace="2" /></a><a href="zafra.html"><img src="greenzafra.jpg" alt="zafra" width="144" height="54" vspace="2" /></a><a href="bellaa.html"><img src="greenadam.jpg" alt="adam" width="144" height="54" vspace="2" /><img src="greenbella.jpg" alt="bella" width="144" height="54" vspace="2" /></a><a href="devin.html"><img src="greendevin.jpg" alt="devin" width="144" height="54" vspace="2" /></a><a href="puppies.html"><img src="greenpuppies.jpg" alt="puppies" width="144" height="54" vspace="2" /></a><a href="photos.html"><img src="greenphotos.jpg" alt="photos" width="144" height="54" vspace="2" /></a><a href="thefuture.html"><img src="greenthefuture.jpg" alt="thefuture" width="144" height="54" vspace="2" /></a><a href="contact.html"><img src="greencontactus.jpg" alt="contactus" width="144" height="54" vspace="2" /></a></p>
                  <p> </p>
                  <p> </p>
              
              

               

              Replace your code with this:

               

              <p><a href="index.html"><img src="greenhome.jpg" alt="home" width="144" height="54" vspace="2" /></a>
              
              <a href="panya.html"><img src="greenpanya.jpg" alt="panya" width="144" height="54" vspace="2" /></a>
              
              <a href="zafra.html"><img src="greenzafra.jpg" alt="zafra" width="144" height="54" vspace="2" /></a>
              
              <a href="adam.html"><img src="greenadam.jpg" alt="adam" width="144" height="54" vspace="2" /></a>
              
              <a href="bellaa.html"><img src="greenbella.jpg" alt="bella" width="144" height="54" vspace="2" /></a>
              
              <a href="devin.html"><img src="greendevin.jpg" alt="devin" width="144" height="54" vspace="2" /></a>
              
              <a href="puppies.html"><img src="greenpuppies.jpg" alt="puppies" width="144" height="54" vspace="2" /></a>
              
              <a href="photos.html"><img src="greenphotos.jpg" alt="photos" width="144" height="54" vspace="2" /></a>
              
              <a href="thefuture.html"><img src="greenthefuture.jpg" alt="thefuture" width="144" height="54" vspace="2" /></a>
              
              <a href="contact.html"><img src="greencontactus.jpg" alt="contactus" width="144" height="54" vspace="2" /></a>
              
              </p>
              
              

               

              HTML & CSS Tutorials - http://w3schools.com/

               

               

              Nancy O.
              Alt-Web Design & Publishing
              Web | Graphics | Print | Media  Specialists
              www.alt-web.com/
              www.twitter.com/altweb
              www.alt-web.blogspot.com

              • 4. Re: links aren't working properly
                jodi77 Level 1

                Dear Nancy:

                 

                I can't thank you enough for your help.

                 

                I fixed my site as you detailed below for me, and it now works.

                 

                Again, I just appreciate that help so much.

                 

                Jodi Distilli

                • 5. Re: links aren't working properly
                  Nancy OShea Adobe Community Professional & MVP

                  Jodi,

                  Glad to be of help.   You can mark this question as answered now.

                   

                   

                   

                  Nancy O.
                  Alt-Web Design & Publishing
                  Web | Graphics | Print | Media  Specialists
                  http://alt-web.com/
                  http://twitter.com/altweb
                  http://alt-web.blogspot.com