4 Replies Latest reply on Jun 15, 2006 11:57 AM by Rannveig Østevik

    WebHelp generation

    Rannveig Østevik
      While trying to solve my SeeAlso text link problem, I've had to regenerate WebHelp for my project a number of times. What I discovered was that when using the compile button in the toolbar that generates the primary layout, the generated WebHelp wasn't working properly. It seemed like it did not use the CSS, and my text links were not working. When clicked I got an error message: "This operation can only function within HTML Help" (the same as when I click the link in preview).

      But when I generate the same project by selecting the primary layout from Single Source Layouts on the Project tab, the project generated correctly. Both with the correct CSS and all the SeeAlso text links working.

      What can cause this difference? I thought the compile button did exactly the same as when choosing Generat from the Project tab?

      Regards,
      Rannveig Østevik
        • 1. Re: WebHelp generation
          RoboWizard Level 4
          Hi Rannveig

          Until you said that your layout that generated correctly was configured as the primary layout, my guess would have been that you were generating from a different layout than primary when it worked, and the primary was something different. This would explain the behavior of the "Quick Generate" icon in the toolbar. I've always believed (perhaps mistakenly) that this button simply performed the same actions as if you double cliked the primary layout.

          What happens if you use the secret keystroke? (Ctrl+M)

          Cheers... Rick :)
          • 2. Re: WebHelp generation
            Rannveig Østevik Level 1
            I'm not sure what caused the problem, but when I tried the same at work today, it all worked OK. The generated WebHelp is correct both when I use the Generate button in the toolbar and when I generate from the Single Source Layouts entry. So there must have been something going on on my computer yesterday that caused the problem. I also tried CTRL+M and the resulting WebHelp is correct.

            Regards,
            Rannveig Østevik
            • 3. Re: WebHelp generation
              HKabaker Level 2
              Rannveig,

              Just a guess:
              Check your browser settings for cache and whether a Web page is always compared with the page in cache before loading.

              I suspect you were seeing the old WebHelp output.

              When I'm in doubt about this, I turn off cache (set to 0) and clear what's there. Problem: IE (6.0 under Windows 2000) demands at least 1 MB for cache. So I clear it manually when testing a re-generated WebHelp, especially if I haven't rebooted the PC.

              Another browser or two (I forget which) use RAM memory cache, so I usually set it to zero and clear what's there.

              Harvey
              • 4. Re: WebHelp generation
                Rannveig Østevik Level 1
                Harvey,

                The problem occurred again today after I posted to the forum. I tried to reproduce it again now, but of course everything works fine when you want it to fail I'm not sure what factors affect this, but I did try to do some of the same things I did earlier today and generated WebHelp several times in a row.

                I will try your suggestion if it fails again.

                Regards,
                Rannveig Østevik