21 Replies Latest reply on Oct 11, 2012 4:38 AM by Jescah1111

    Unable To Click in Flash Player Settings Box


      I have Mac 10.6.1 and recently installed flash player 10 when i was using safari as my browser. I now have switched to firefox and when i try to webchat online and the flash player settings box pops up asking if i would like to allow access to my camera and microphone i can't click on anything. nor can i click on anything on the current web page behind.


      i have already used safari and clicked allow access and for flash player to remember this choice, but it still wont allow me to change devices while using Firefox,


      I have tried to just using my keyboard to "tab" to the options i want. I am able to highlight certain parts of the Flash Player Settings box but the enter button has no effect.


      Any ideas guys lol it'ld be much appreciated, im thinking it might be because i installed flash player while using safari and then downloaded firefox recently as a browser, but im not sure and dont want to go changing/uninstalling (if u can even do that on a mac) things until i get an idea of wtf is wrong,


      Thanks a bunch sean

        • 1. Re: Unable To Click in Flash Player Settings Box
          eidnolb onlyone Level 5

          Hello, Flash Player must be installed into each browser, since it is a browser plug-in. Use FF and install it as you did using Safari.


          Flash Player has released the latest version and it is Hope that helps.






          • 2. Re: Unable To Click in Flash Player Settings Box

            Try this, worked for me:




            The important text from the upper site:


            "This is a fix for quite a few mac flash 10 problems I noticed people talking about on the internet.


            I know this is getting old but make sure you fix permissions first. Then in your home folder delete the Flash Player folder that is inside both Library/Caches/Adobe and Library/Preferences/Macromedia.


            For some reason Flash Player is unable to properly write data to those folders even after an uninstall and reinstall. This is probably due to corruption of the folders. I think Adobe should try to find out what causes the corruption after an upgrade."


            Hope this helps anyone! It solved the problem for me.



            Sergio Azenha


            1 person found this helpful
            • 3. Re: Unable To Click in Flash Player Settings Box
              eidnolb onlyone Level 5

              Hi micha231,


              Glad that solution worked for you. However, this isn't the problem that ScotianBoy is having nor is concerned with.


              His issue is Firefox and the Global Settings, and it is those issues that I will address.


              The link you provided is from November 2008 and much has changed since then.


              Also, in that internet link that you cited  the statement "For some reason Flash Player is unable to properly write data to those folders.....etc. Then it suggests to delete the Flash Player folder. What is causing the "corruption" Flash Player???


              In other words, the Adobe Flash Player isn't available for MAC users. That makes no sense, Adobe has provided Flash Player for MAC for quite some time.



              I don't have the time to discuss this further. If whatever you followed from the Internet and it worked for you, that's great.  However, as I seem to have had to repeat myself on various threads concerning the same issue, there are many risky suggestions and advice on the Internet. One is that you do not follow a solution before you know what the problem is.




              • 4. Re: Unable To Click in Flash Player Settings Box
                eidnolb onlyone Level 5

                Hi ScotianBoy, Just a follow up to see if you installed the Flash Player into the Firefox browser. If that is working for you and you need some help on setting the Global Settings, let me know.








                1 person found this helpful
                • 5. Re: Unable To Click in Flash Player Settings Box
                  micha231 Level 1



                  I'm sorry but you are on the wrong track here. The problem that the the original poster is having is EXACTLY the same problem as I had.


                  You are also wrong with the statement that the flash player plugin on mac needs to be installed seperately for each browser. This is not true. If a mac user has Safari AND Firefox on his machine then he can download and install the plugin on either browser and the plugin will also work in the other one.


                  The bug which is the problem here exists mainly on Unix Operating Systems (Linux and Mac) and I is caused by a flash plugin update which then "corrupts" the mentioned folders on the machine. After that the flash player plugin can't read or write to these folders anymore which then causes specific flash movies (movie players, games, flash apps) to not behave properly since they can't read or write cookies/settings from or to the users machine. These folders can be safely deleted because as soon as the flash player is started again these folders will be created again.


                  I don't understand your part where you write about the flash player plugin not existing on mac at all. Of course (I agree with you) the flash player plugin exists for Unix Machines. There are just some bugs (like the above mentioned one).


                  I followed all the threads which have the same bug on this forum. Every solution proposed in these threads didn't work and quite frankly are just general solutions to specfic problems (i.e. updating flash player plugin, unistalling/reinstalling, etc.)


                  However I appreciate your work and dedication to help everyone in this forum.


                  Best regards,



                  • 6. Re: Unable To Click in Flash Player Settings Box
                    eidnolb onlyone Level 5

                    Hi micha231, seems like I've had this conversation before with someone that had a different screen name.


                    All I can tell you is that there have been MAC users on this Flash forum that I have assisted and they solved their

                    Flash Player problems without doing anything that you have suggested nor going to the Internet nor even discussing what you just related. If whatever you did and it solved your problem, that's great. Some people reformat their hard drive too, but that is not the solution for everyone.


                    I do not mind you or anyone else pointing out anything that I suggest or advise is incorrect. I am always willing to learn from those that know more about something than I do.


                    But what I do object to is for you or anyone else telling me that I cannot read nor comprehend. In this case, the subject of

                    his thread should clue anyone in what his post was going to be about. "Unable to Click in Flash Player Settings Box"

                    Another quote from his first post: "...the flash player settings box pops up asking if I would like to allow access to my

                    camera and microphone." This is clearly related to the Global Settings, and in particular to the Website Privacy

                    Settings that the user has set. Had he not previously set them, he would not have been asked for permission for the site to access his camera or microphone.


                    You need to read about the Global Settings.


                    And no the problem that ScotianBoy stated is NOT the same problem as you had. You mention nothing about Global Settings. You speak of bugs and like I said I have heard this "bug" stuff before. Well, my Flash Player works perfectly and

                    "if" it has a bug, which I don't believe it does, it certainly is not bothering me, my computer or any site I choose to access, videos, TV on line, radios, live streaming or anything else that is out there.


                    It appears to me in this reply of yours and the one you made to ScotianBoy, is that you have something against Adobe and just want to post your agenda whereever you can. Normally I don't reply to your kind of attacks. But to come on this thread and make a statement that this thread was not about Global Settings and then insult me by saying that I can't read nor comprehend, no dearie, you won't get a pass from me on that. If I could I would ask every user on this forum to vote and my question would be "Is this thread as ScotianBoy posted about Global Settings, or is it about "bugs"



                    • 7. Re: Unable To Click in Flash Player Settings Box
                      micha231 Level 1



                      I'm not trying to insult you nor start an anti-adobe flamewar.


                      Maybe I didn't make myself clear about the bug itself.


                      Yes, this bug (the same I had) is affecting the Global Settings Panel. I myself couldn't also change (like checking/unchecking boxes) the Global Settings. Any settings that could be changed weren't saved. This is because the flash player plugin couldn't access the mentioned folders to save these settings. The Global Settings Panel is linked to local folders on the machine and if these folders aren't accessible then the problems like the original poster stated appear.


                      Normally there is no need at all to configure the Global Settings Panel since the default settings are working for everyone. After the deletion of these local folders the Global Settings Panel has its default setting and everything is working again.


                      In the end a bug is still a bug. I'm not blaming Adobe because every software has its bugs. It might be possible that Adobe needs to improve the update routine for Unix machines.


                      In my opinion bug-reports by users in this forum have to be extremely differentiated between Windows and Mac OS in the first place since possible workarounds/solutions are besides updating/uninstalling/reinstalling completely different.


                      Again, no offense regarding whatsoever


                      Best regards,



                      • 8. Re: Unable To Click in Flash Player Settings Box

                        I get this same issue in Windows 7 x64 Ultimate.


                        If you right click a flash application, and click settings the dialog shows, but I can't click anything. 

                        I also cannot close that settings box, forcing me to reload the page since the application becomes unusable.


                        I also cannot allow/deny webcam and microphone access on tinychat.


                        This is really irritating, and there is mention of the bug throughout google (search for "flash can't click")

                        • 9. Re: Unable To Click in Flash Player Settings Box
                          eidnolb onlyone Level 5

                          Hi, didn't see that you replied to the person that replied to the original person that started the thread. I would suggest that you would probably be better served to start your own thread.


                          This is what is recommended, gets too confusing otherwise. And especially on this thread since the person that took the

                          time to start this thread evidently has solved his problem and marked it as answered.





                          • 10. Re: Unable To Click in Flash Player Settings Box



                            Just a quick note of thanks for your suggestion.  I had a similar problem to the original poster: Mac OS 10.6.2, upgraded to from the previous version and lost the ability to change global storage settings.   After a lot of looking around and trying different things unsuccessfully, I finally found your post and it solved the problem.



                            • 11. Re: Unable To Click in Flash Player Settings Box

                              I had the same problem as the original poster. I couldn't change the settings. From the Settings manager I could move the slider, but none of the changes made stuck. They changed back. Especially the Global Storage Settings were always set to none, which resulted in me not being able to watch some videos or listen to Myspace music players, or change camera settings etc.

                              I'm also on OS X Snow Leopard and the things micha231 mentioned DO work. It IS an issue/ bug with updating the Flash plugin from Adobe. I could even reproduce it by installing again.

                              To make it work again however, I needed to add one more step to the given instructions. I had to delete the mentioned folders after the new install again, not only before updating.

                              Thanks to micha231, I've been searching for a solution the last 2 days, but now it works

                              • 12. Re: Unable To Click in Flash Player Settings Box
                                Dimitry Zolotaryov'

                                I was able to fix it by right-clicking the Flash Player directory under Library/Preferences/Micromedia/ and changing the permissions to allow write for staff and everyone.


                                Hope this still helps someone.

                                • 13. Re: Unable To Click in Flash Player Settings Box

                                  Hey Blondie backwards. Micha is 100% correct, and was not doing anyone a disservice by providing information, as YOU are in trying to discount the information provided. I started an account here specifically to point this out to you. When I tried to report you there was an "unexpected error" so I guess your butt is covered. Goodbye forever.

                                  • 14. Re: Unable To Click in Flash Player Settings Box
                                    aintnosleeves Level 1

                                    I too have seen this issue many times on Firefox on Mac OS X. I've even seen come and go just based on changes to a flex .swf I'm building. This is clearly a Flash Player issue that needs to be resolved.

                                    • 15. Re: Unable To Click in Flash Player Settings Box

                                      I have the same exact problem as the original poster... works fine in Safari, but I can't click in the settings pop up box in Firefox. Neither eidnolb or micha's solutions worked. I have flash installed in FF and can see everything that uses flash in Forefox - all I CANNOT do is edit the settings to allow sites that need to access my camera like dailybooth.com in Firefox. I'm on Mac OS X version 10.6.6 and Firefox 3.6.1. I got this iMac two or three weeks ago, so this wasn't an upgrade, but rather an installation of flash. It's very fristrating to spend 3K on a machine and then not be able to edit a basic feature like this. :/

                                      • 16. Re: Unable To Click in Flash Player Settings Box
                                        eidnolb onlyone Level 5

                                        Hi, Each thread that is started will have their own issue and computer information. It isn't intended to be advice for everyone as the solutions are addressed to that posting. Addons/Extensions/Anti-Virus/Programs/Updates and so on can make a great difference in solutions.


                                        That is why there are separate threads/discussions/topics. This thread is answered and it is a year old.


                                        It would be better if you started your own discussion.






                                        • 17. Re: Unable To Click in Flash Player Settings Box

                                          Unfortunately, for many people, the "Fix Permissions and Delete this-and-that prefs folders" solution simply does not work. Google it, there are tons of people having this problem. After making it my personal mission to find a solution to this issue which has been plaguing me for a year now, I found a workaround that should work for most:


                                          Funny though this may sound, go to MegaVideo.com, play any video, choose Full Screen button, then right click and choose Settings. This will enable you to access the Flash Control Panel settings to make any changes. You'll still be bugged with no-click-ability when you return to the window view, but at least you were able to change your settings.

                                          • 18. Re: Unable To Click in Flash Player Settings Box

                                            Thanks Mantis for your persistency in solving this issue - megavideo is a very crappy video site I have to say, all the video "play" buttons lead to all kind of ads from webcam chat girl to DivX installation..... even though it somehow solved my problem I still feel disgusted by simply visiting that site; Now I'm just wondering could I have done the same (right click on a playing video) on any other tasteful site to solve the problem.


                                            Anyway, thank you! This bug really sucks. I truly hope Adobe team would solve it soon.

                                            • 19. Re: Unable To Click in Flash Player Settings Box

                                              same **** happend to me on my macbook after upgrading,

                                              you can visit these settings via System Preferences > Flash Player (in Other),

                                              without heading any website

                                              • 20. Re: Unable To Click in Flash Player Settings Box

                                                Same problem on Ubuntu Linux.  Deleting all the adobe/macromedia settings files did not correct the issue or change the symptoms.


                                                I worked around it by using the "Global Settings" option instead, and creating entries for the site I was trying to enable.


                                                This is in the Ubuntu bug-tracker as https://bugs.launchpad.net/ubuntu/+source/adobe-flashplugin/+bug/865672, and appears to affect a lot of users.

                                                • 21. Re: Unable To Click in Flash Player Settings Box

                                                  I coundnt click anything either - Just could use tab.


                                                  I experimented around a bit - Hold Tab+Spacebar.


                                                  That allowed me  to select things..


                                                  Hope this works for you