2 Replies Latest reply on Nov 5, 2008 12:40 PM by stevenickname

    Classpath settings and error messages (Flash 8)

    stevenickname
      I work for a large corporation and my Flash 8 is installed on a remote server (?) somewhere; it is not on my C drive. Last year I had a Classpath problem to the external actionscript files that was solved when I learned how to browse to the files and add a path under Preferences. The correct path started like this C:\apps_pub\FLSH8010... (longer path deleted). Everything worked fine after that.

      Recently I tried to "compile" the fairly complex file that we created last year, and the "old" error messages came up...
      sample: **Error** C:\Documents and Settings\sm87191\Local Settings\Application Data\Macromedia\Flash 8\en\Configuration\Classes\FP8\MovieClip.as: Line 36: The class or interface 'flash.geom.Rectangle' could not be loaded.
      I checked PREFERENCES and the path I had added last year had disappeared. I think maybe corporate IT reinstalled our apps without telling us. So I browsed to the same location as before, everything looked fine, and I added the path... BUT I am still unable to compile. Still getting six error messages.


      It seems to me that Flash is looking for the actionscript in the "wrong" place. I told Flash to look in apps_pub (under Preferences), but for some reason it is looking in "Documents and Settings". At least that's how it looks to me. How do I tell Flash NOT to go to "Documents and Settings"??? Why is it going there? (I checked Publish Preview too... looks OK)