16 Replies Latest reply on Feb 17, 2010 7:54 AM by the_wine_snob

    Choppy playback from timeline - used to be fine

    Prizm4 Level 1

      I can't figure out what happened to playback in my CS4. It's choppy unless I shrink the preview size down to like 10%. I'm running a Q8400 with 4GB RAM, Win7 64-bit, and an ATI HD4850.

       

      I'm using a PAL Canon HV30 shooting at 1440x1080, 25p. It's recording onto MiniDV tape.  I have edited plenty of footage previously using the same setup, and have never had playback problems. It used to playback nice and smooth no matter what size the window was. When I say the playback is choppy, I mean it's playing at maybe 18fps. It could be worse, but it's enough to make editing to music unworkable unless I shrink the preview size.

       

      My current project settings are the "HDV 1080p25" preset.

       

      I also just edited some NTSC DVD footage using the standard DV-NTSC preset, and was experiencing a similar problem of jerky playback.

       

      The only thing I can think of that has changed recently is my video card.  I used to have a GeForce 8600GT, and I've switched to an ATI HD4850. The card is 3x faster for games than my old card, but does CS4 support ATI properly? I'm not totally sure, but I think this is the first time I've edited footage since getting the new card. And yes, I have the latest ATI drivers installed.

       

      thanks

        • 1. Re: Choppy playback from timeline - used to be fine
          Harm Millaard Level 7

          ATI works fine. Your sequence setting may be the problem, because the HV30 does not record true P because it wraps everything in i format. Try with an i preset.

           

          Apart from that, 25P is not allowed or supported with BR.

          • 2. Re: Choppy playback from timeline - used to be fine
            MonkeyRei

            Harm makes a good point - it could be the preset, since the camera would be shooting a progressive style image, but recording that as an interlaced signal to tape, so in fact you've got 1080i that looks like 1080p. So choosing an interlaced preset would mean premiere didn't have to struggle to play it back.

            However - you say it used to be perfectly smooth, did you use the same preset then as well? If so, and this is a long shot, choppy playback can occur as the hard drive fills up, using slowest areas of the drive (ie an empty drive is very fast, the last sectors to fill up are the slowest). Defragging can help, but best to empty the hard drive much as you can, or get another... could this be the case?

            • 3. Re: Choppy playback from timeline - used to be fine
              Prizm4 Level 1

              Thanks for your replies guys.  Nice to have some clarity about what format this camera records in. I've always been unsure what project settings to use because of the weird way it records 25p.

               

              Anyway - creating a project that is 25i does improve things a little bit. Now I can make the window up to 25% before it starts to get choppy.  The thing is, I never used to have this problem at all, even with the (incorrect) project settings at 25p.   I hear what you're saying about the hard disk. I've checked Defrag, and it says the drive is 0% defragmented, so I don't think that's it either.

              • 4. Re: Choppy playback from timeline - used to be fine
                Harm Millaard Level 7

                One thing worries me. You mention "the hard disk". The lack of the plural form is indicative of a system below minimum requirements. What is your disk setup?

                • 5. Re: Choppy playback from timeline - used to be fine
                  MonkeyRei Level 1

                  It feels a bit like something is hogging cpu power... installed anything recently? You've got windows7, so try looking at the Reliability and Performance Monitor - go to start menu, in the search field at the bottom just type in 'performance monitor' and hit enter - that should bring it up. Then click the CPU bar to see what processes are using most cpu power. Anything odd there?

                  • 6. Re: Choppy playback from timeline - used to be fine
                    Prizm4 Level 1

                    > One thing worries me. You mention "the hard disk". The lack

                    > of the  plural form is indicative of a system below minimum

                    > requirements. What  is your disk setup?

                     

                    Harm, it wouldn't be below minimum requirements if it was working perfectly before.  I have my OS on one drive, and my video footage on a second 7200 SATA drive. My OS drive used to be a Raptor, which has since changed, but video footage has never been stored on my OS drive. I've been doing this for years and I've never had playback problems before - even with HDV footage.

                    I just checked my project that uses NTSC DVD footage - everything is rendered and yet it too has choppy playback, probably at around 20fps. Unless I make the preview window smaller. This is really strange.

                     

                    I might be wrong, but if the hard disk was the problem, wouldn't it struggle to playback no matter what size the preview window is?

                     

                    Froppy:  Thanks for your suggestions. Nothing else of significance is running in the background. I don't use anti-virus/net security software, and there's no spyware programs in the background either.

                     

                    I just did a test of both DVD footage and HDV footage with the preview window size being roughly 740x552:

                     

                    DVD footage playback (pre-rendered): 32-36 CPU usage by PremierePro.exe

                    HDV footage playback (raw, no render required): 29-33 CPU usage by PremierePro.exe

                     

                    The usage is spread out evenly across all four cores. There's not much CPU usage considering, but playback was choppy. Notice that the DVD footage was actually slightly more CPU intensive than the HDV footage.  Maybe I should look for some kind of hard disk meter program to see if the HD is being maxed out for some reason?   I'm still suspicious about the display adapter though.

                    • 7. Re: Choppy playback from timeline - used to be fine
                      Bill Gehrke Most Valuable Participant

                      My favorite question:

                       

                      How many processes are running before you start Premiere?  If you have not tuned Win 7 you could have about 70 processes running,  Get that down into the thirty's and you will have an editing system.

                      • 8. Re: Choppy playback from timeline - used to be fine
                        the_wine_snob Level 9

                        Along the lines of Bill's comments, I use the tips in this ARTICLE prior to any editing session.

                         

                        Good luck,

                         

                        Hunt

                        • 9. Re: Choppy playback from timeline - used to be fine
                          Prizm4 Level 1

                          Thanks for the suggestions. As for Processes, I have 42 running. To remove any of those would be scraping the barrel - these days that sort of stuff won't make much difference at all. I've already made sure not to have bloated stuff on my system like Nortons, etc.

                           

                          As for the suggestions in the article, I noticed that my drive has Indexing enabled (which must've just been turned on recently), so I'll turn that off and give it a shot.

                           

                          EDIT: I just loaded up Sony Vegas and imported the same HDV file to see how it would play back.  It plays as smooth as butter on a preview window twice as big as I tested in Premiere Pro. Once again, I'm suspicious of Premiere's support for display adapters.

                          • 10. Re: Choppy playback from timeline - used to be fine
                            Matt Petersen Level 3

                            Worth fiddling with the Program Monitor display quality too. Try all three settings to see if it makes any improvement.

                             

                            also, check your sound settings. an issue with a sound card or driver could also cause choppy playback.

                             

                            Funny that Vegas has no trouble, but you can never really be sure what other apps are doing in playback (like choking the bitrate or paying half-fields or half-res).

                             

                            MP

                            • 11. Re: Choppy playback from timeline - used to be fine
                              MonkeyRei Level 1

                              I know I was caught a while back with something like this, watching stuff smoothly in 'draft' mode, then wondering why it was choppy in High Qual mode (not realising because of the widow size that it was draft mode originally). But - if that's not the case...

                               

                              In Vista (64bit) I had to turn off *all* the cool new graphic things vista can do, which basically comes down to one main switch in the Windows visual effects options (in windows) - Desktop Composition. I definitely had to do this with my old 9800GT, and haven't turned it back on since upgrading to a quadro 580.

                               

                              Try: Control Panel>System and Maintenance>Performance Information and Tools, then click 'Adjust Visual Effects' on the left, and turn off Desktop Composition.

                              To scratch that video card issue itch you have, perhaps your old card and new card handle this differently in relation to Premiere. Worth trying anyway...

                               

                              good luck!

                              • 12. Re: Choppy playback from timeline - used to be fine
                                Prizm4 Level 1

                                Yeah, I also thought Vegas was pulling a stunt on me, so I made sure the preview settings were set to Best (Full), and it plays great with no jerkiness.

                                 

                                With Premiere Pro, I forgot to mention that I had tried the different quality modes (Draft, Automatic, etc). They made little difference.

                                 

                                Here's a couple things I just tried:

                                 

                                - Tried playback after disabling Indexing on the drive, no change

                                - Turned off Desktop Composition, no change

                                - I had recently installed updated Realtek audio drivers. I uninstalled them and let Windows install its default audio drivers. No change.

                                 

                                Well, I'm out of ideas. Thanks for all the suggestions though.  It's funny, the reason I installed new audio drivers is because of another Adobe program: Audition. It kept crashing on startup. It came down to a missing font of all things. Because my system was missing Tahoma.ttf, Audition would not load. Delete Tahoma.ttf and see it for yourself

                                 

                                Anyway, I'm just going to have to use Vegas for my video. So far things have been going well and the interface is very responsive which is nice.

                                • 13. Re: Choppy playback from timeline - used to be fine
                                  MonkeyRei Level 1

                                  Hmmm I've been ignoring Vegas all these years, perhaps that was a mistake...

                                  good luck with it.

                                  • 14. Re: Choppy playback from timeline - used to be fine
                                    SpareWheel Level 2

                                    Hi.

                                     

                                    You say:

                                     

                                    The only thing I can think of that has changed recently is my video card.  I used to have a GeForce 8600GT, and I've switched to an ATI HD4850. The card is 3x faster for games than my old card, but does CS4 support ATI properly? I'm not totally sure, but I think this is the first time I've edited footage since getting the new card. And yes, I have the latest ATI drivers installed.

                                     

                                    I would think this rings an alarm bell somewhere...

                                     

                                    Would not changing the video card back to your earlier version at least help eliminate video driver issues if you have found none of the other suggestions have worked - especially if this is probably the first edit you have done since changing out the card. Perhaps you do have a video issue and not one relating to Settings or HDDs.

                                     

                                    Just a thought?

                                     

                                     

                                    • 15. Re: Choppy playback from timeline - used to be fine
                                      jpw21683
                                      function(){return A.apply(null,[this].concat($A(arguments)))}

                                      Drystonewall wrote:

                                       

                                      Hi.

                                       

                                      You say:

                                       

                                      The only thing I can think of that has changed recently is my video card.  I used to have a GeForce 8600GT, and I've switched to an ATI HD4850. The card is 3x faster for games than my old card, but does CS4 support ATI properly? I'm not totally sure, but I think this is the first time I've edited footage since getting the new card. And yes, I have the latest ATI drivers installed.

                                       

                                      I would think this rings an alarm bell somewhere...

                                       

                                      Would not changing the video card back to your earlier version at least help eliminate video driver issues if you have found none of the other suggestions have worked - especially if this is probably the first edit you have done since changing out the card. Perhaps you do have a video issue and not one relating to Settings or HDDs.

                                       

                                      Just a thought?

                                       

                                       


                                      This.

                                       

                                      Also, when you switched from NVIDIA to ATI, did you remove all the NVIDIA drivers and run a driver cleaner first?

                                       

                                      I'm using an ATI HD4650 on Win 7 x64 and have no issues in PPro CS4.

                                      • 16. Re: Choppy playback from timeline - used to be fine
                                        the_wine_snob Level 9

                                        Two things that I did not see mentioned yet, that can affect playback are"

                                         

                                        1.) Hardware Acceleration - if max, set to min. If min, set to max. If this helps, then increment, until thing go wonky again, and then move up/down by one notch.

                                         

                                        2.) Check your OpenGL settings (probably in your ATI console)

                                         

                                        If you've checked those two things, then never mind.

                                         

                                        Good luck,

                                         

                                        Hunt