14 Replies Latest reply on Feb 16, 2010 12:32 PM by the_wine_snob

    Imported .gif has black background

    rico1931 Level 1

      Hello All,

       

      I imported a .gif with a transparent background but when I try to use the logo in cs4 premiere Pro it has a black background. I can't figure out how to take out the black background. Any help would be appreciated.

       

      Thank you

      -rico

        • 1. Re: Imported .gif has black background
          Curt Wrigley Level 4

          How are useing the Giff?  Putting it in a layer above your background?   Can you post the gif here so we can check it out?

           

          Try adding the attached in a layer above your video and see if it works.

           

          And; What seq preset are you using in the project?

          • 2. Re: Imported .gif has black background
            the_wine_snob Level 9

            Also, if you are using it by itself and want, say a white background, you can place a white Colored Matte on Video Track 1, with your GIF on Video Track 2, and you'll have the colored background (so long as your GIF has a transparent background.)

             

            Good luck,

             

            Hunt

            • 3. Re: Imported .gif has black background
              rico1931 Level 1

              Hi Curt,

               

              I am putting it in the layer above my background which is a video clip. I'm trying to scroll my logo over my video clip with no background. I made the image in photoshop and works fine on my web..has a transparent background and everything.

               

              As for the image you provided me I put it in the layer above my video clip and it had the same black background that I have with my logo. Also I'm pretty new to Premiere and not sure what you mean by sequence presets. I just chose the one that came as default and began with my project.

               

              Thanks

              • 4. Re: Imported .gif has black background
                rico1931 Level 1

                Hi Hunt

                 

                I'm not sure what you are saying. I made a title and wanted to put a logo of my company in the title but each time I right click in the text box and place logo and find my .gif image it still has the black background. I just want the image to show with the text as it scrolls over the clip with no background inserted

                • 5. Re: Imported .gif has black background
                  the_wine_snob Level 9

                  The Project/Sequence Preset should match your source footage 100%. Please tell us about that source footage, and someone can tell you exactly which Preset you should use.

                   

                  Good luck,

                   

                  Hunt

                  • 6. Re: Imported .gif has black background
                    rico1931 Level 1

                    Oh geeze I feel like such a noob ...

                     

                    oh well my source footage was a tape so DV video and i'm using it at 720 x 480

                     

                    but some how I think this is not what you are asking... But hey guys guess what.. just clicking away on things i figure it out

                     

                    Apparent;y to get the black background out of your image you need to import a .png logo file.. once I did that it was all good.. thanks again ..

                     

                    I will try to be more active now in the forum I like playing with this new fun toy I have

                     

                    -rico

                    • 7. Re: Imported .gif has black background
                      the_wine_snob Level 9

                      Sorry.

                       

                      That reply was going out, just as your comments on usage was coming in. Ignore my suggestion on the Colored Matte, as that is NOT what you want.

                       

                      Is this close (disregard the size) to what you are trying to do?

                      GIF_Logo.jpg

                       

                      This is just using your GIF on Video Track 2, with the video Asset on Video Track 1.

                       

                      Good luck,

                       

                      Hunt

                      • 8. Re: Imported .gif has black background
                        Colin Brougham Level 6

                        GIF "works"... it's just not a great video format. I was able to get your file overlaid on video without a problem, as Bill was able to as well--my guess is that somehow the alpha channel was being ignored. You can check that by right-clicking on your file and selecting Interpret Footage; the alpha channel options are at the bottom of the panel. If "Ignore Alpha Channel" is checked, uncheck it and see what happens.

                         

                        You can use PNG, as you've discovered--but why not just import the PSD file? Much less to keep track of, plus you can import it as a sequence with each layer on its own track so you can easily animate it. Just a thought...

                        1 person found this helpful
                        • 9. Re: Imported .gif has black background
                          the_wine_snob Level 9

                          Both PNG and GIF (or even PSD) can have Transparency. I did an example with your supplied GIF, and think that it worked fine. Now, I did not use it as a Logo in a Title, and only placed it onto a higher Video Track.

                           

                          One can animate/resize that with the fixed Effects>Motion>Scale and Motion>Position. To animate, one would Keyframe those Effects. I just used your GIF static - no Effects manipulations and no Keyframes.

                           

                          As for your Project/Sequence Preset, you probably got the DV (NTSC, or PAL) and that will work fine for your miniDV tape 720x480. Only variable will be whether it's Standard (4:3), or Widescreen (16:9), but if you do not see black bars around your frames in the Program Monitor, you probably got that perfect too.

                           

                          Hope that this helps, and good luck,

                           

                          Hunt

                          1 person found this helpful
                          • 10. Re: Imported .gif has black background
                            Curt Wrigley Level 4

                            Your gif works for me also.

                             

                            But; IF you have this graphic in PS; you are much better off saving it as a regular PS file (PSD) with a transparent background and importing that into Pr.  This will give you better quality than a gif.

                             

                            Edit: Posted the same time as Colin and Bill. Sry for the duplicate info... They both nailed it.

                            • 11. Re: Imported .gif has black background
                              the_wine_snob Level 9

                              Colin,

                               

                              I use .PSD's for most of my similar work, as that is the native format for me. I assumed that the OP had the GIF already, and as it would work for the indexed color artwork, just left that part alone. Since all Video will be a Raster image, I'd just Save_As PSD from PS, but that's my normal workflow.

                               

                              Hunt

                              • 12. Re: Imported .gif has black background
                                the_wine_snob Level 9

                                Curt,

                                 

                                Seems that a lot of replies are bumping into each other - really active morning!!!

                                 

                                Hey, so long as we're all on the same page, can't be too bad, eh?

                                 

                                Also, the OP got some more tips, all from one question. Talk about value...

                                 

                                Good luck, and good day to all,

                                 

                                Hunt

                                • 13. Re: Imported .gif has black background
                                  rico1931 Level 1

                                  Hunt that is exactly what I want but for some reason just placing it on a higher track didn't do the trick.... What I did notice is that my whole movie for some reason has a black background. Seeing your clip i notice it just had the grey background.. Not sure why but I guess I will just have to find out for my self in the future.

                                   

                                  Colin I did try your suggestions and still no luck. Both checked and unchecked. also tried to invert it and nothing..

                                   

                                  Well PNG seemed to work.. I guess with my next project I will bookmark this page and try it with a fresh slate...

                                   

                                  Thanks to everyone that has helped me!!!

                                   

                                  -rico

                                  • 14. Re: Imported .gif has black background
                                    the_wine_snob Level 9

                                    What you saw in my example was the Program Monitor expanded beyond the Frame Size of the Assets. If you are seeing black surrounding, then there is probably an issue between the Project/Sequence Preset and the actual source footage. Now, this might take a bit of interpolation, as there are some major changes between my PrPro 2.0, and CS4, but it should be similar enough that you can fill in the blanks, if I am clear enough. Or, it could just be a difference between the GUI in CS4 vs my PrPro 2.0.

                                     

                                    For me, Presets apply to entire Projects. For you, they can be applied to individual Sequences. If I need to find out what Preset was used (and any custom settings, should I have chosen Desktop), I would go to Project (in the Toolbar), and look at Project Settings. You should be able to do the same from the Sequence in the Toolbar. That should give you all of the settings. You can then Rt-click on your AV Asset and choose Properties. These should match in every respect.

                                     

                                    Now to the GIF. When you drag it to a Video Track, higher than your Video Clip, you still get that black background? This is not when used on a Title, but just as an Asset on the Timeline. Are there any Effects applied to the Logo?

                                     

                                    One more question: are you observing the display in the Program Monitor, and not in the Source Monitor. They look very similar, but are different displays. To get to the Program Monitor, if it is not Open, go to Window>Program Monitor. Note: it might be docked in a Pane, with other Monitors, or Panels, so you might need to find its tab, and click on that. To view in the Program Monitor, you will just drag the CTI (Current Time Indicator w/ the red Edit Line extending down from it) so that it is over both your GIF and also your Video Asset (on a lover Video Track). This will then display in the Program Monitor.

                                     

                                    I did not alter the GIF that you attached, in any way - no Scaling, no Effects, no Motion - just Import and drag into position. I am puzzled why this is not working exactly the same way for you.

                                     

                                    Now, Colin mentioned the Alpha Channel and its checkbox. Have you followed his directions there? I keep Use Alpha Channel checked, and had not even though about that.

                                     

                                    Good luck, and please let us know what you find out,

                                     

                                    Hunt