2 Replies Latest reply on Oct 2, 2007 12:27 PM by jeffdafoe

    FB3B2 unable to import WSDL files that contain XSD imports

    jeffdafoe
      Much to my dismay, the new WSDL import wizard does not seem to work on WSDL files that import XSD files. When "Finish" is pressed, an error dialog states "The WSDL definition could not be parsed. The wizard cannot complete successfully."

      I created a sample WSDL that uses the most basic of XSD files to demonstrate. Remove the import line from the WSDL and it will import, with the line it will not.

        • 1. Re: FB3B2 unable to import WSDL files that contain XSD imports
          Lăcră Ene
          Hi Jeff,
          How are you specifying the WSDL URI?
          - If as an absolute path on your machine, make sure there are no spaces in that path – there is a known issue about path with spaces and WSDL with imports, and we’re on it. We tried out your sample WSDL this way and it works.
          - If you are specifying it as an HTTP url (accessing it over the Apache HTTP server, for example), the workaround is a little more complicated. There are indeed some unresolved issues with the ActionScript generator. Try putting the wsdl and xsd files inside a folder in the webroot, and another copy of the xsd in the webroot. This worked for me - the problem is about locating the imported document correctly: the introspection correctly uses the sibling xsd file, while the generator incorrectly looks for that file one level up. We’ll look into this and fix it.
          Please let me know if it starts working or if it still does not generate the ActionScript client classes. Thank you.
          Also, please be aware of another known issue about WSDL with imports: http://bugs.adobe.com/jira/browse/FB-7678 (For WSDLs that import other documents, the cached WSDL file should include the content of the imported documents).
          Lacra
          • 2. Re: FB3B2 unable to import WSDL files that contain XSD imports
            jeffdafoe Level 1
            Lacra,

            Thank you for taking the time to respond. I am specifying the WSDL file as a HTTP resource. I followed the workaround that you mentioned in your second bullet point, which was to copy the XSD files up one directory, and was met with success. The importer reproduced a fairly complex XML schema with no further isue.