11 Replies Latest reply on Jan 22, 2008 12:37 PM by Kevin Goldsmith

    Not working on my MacBook

    ondadiluce
      I installed the toolkit on my MacBook but it crash at the startup. I don't know what can be the problem, but this is the error mesasage:

      Date/Time: 2007-10-02 10:31:36.668 +0200
      OS Version: 10.4.10 (Build 8R2218)
      Report Version: 4

      Command: newIDE
      Path: /Applications/AIF Toolkit/AIF Toolkit.app/Contents/MacOS/newIDE
      Parent: WindowServer [65]

      Version: ??? (???)

      PID: 265
      Thread: 0

      Exception: EXC_BAD_ACCESS (0x0001)
      Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000014

      Thread 0 Crashed:
      0 AdobeBIB 0x0071ae48 BIBInitialize2 + 21562
      1 AdobeBIB 0x0071aefe BIBInitialize2 + 21744
      2 AdobeBIB 0x0071dfa5 0x712000 + 49061
      3 image_flow 0x014be589 BIB_T_NMT::CBIBError::~CBIBError [in-charge]() + 33
      4 image_flow 0x014b57d5 cxa_atexit_wrapper + 115
      5 libSystem.B.dylib 0x900103e1 __cxa_finalize + 226
      6 libSystem.B.dylib 0x900102e8 exit + 24
      7 com.adobe.AIFToolkit 0x00002c8e _start + 224
      8 com.adobe.AIFToolkit 0x00002bad start + 41

      Thread 1:
      0 libSystem.B.dylib 0x900248c7 semaphore_wait_signal_trap + 7
      1 ...ple.CoreServices.CarbonCore 0x90cb8e11 MPWaitOnQueue + 198
      2 AdobeACE 0x01f6e3fb 0x1f3f000 + 193531
      3 AdobeACE 0x01f6dc29 0x1f3f000 + 191529
      4 ...ple.CoreServices.CarbonCore 0x90cb8c6c PrivateMPEntryPoint + 51
      5 libSystem.B.dylib 0x90024227 _pthread_body + 84

      Thread 0 crashed with X86 Thread State (32-bit):
      eax: 0x00000000 ebx: 0x0071ae8a ecx: 0x010ca95c edx: 0x010ca95c
      edi: 0xbffffb74 esi: 0x010ca9ac ebp: 0xbffffb88 esp: 0xbffffb60
      ss: 0x0000001f efl: 0x00010206 eip: 0x0071ae48 cs: 0x00000017
      ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037

      more in attachment...

      thank you for your help
      mauro
        • 1. Re: Not working on my MacBook
          cprosser_(adobe) Adobe Employee
          Hi,

          I'm sorry the AIF toolkit is crashing for you. It shouldn't crash, but should give you an error that the MacBook doesn't have a decent enough graphics card. The MacBook contains an integrated graphics subsystem that doesn't support enough OpenGL to use the toolkit.

          The Flash Player and final version of the toolkit will not have these limitations.

          Thanks for your patience,

          Chris Prosser
          Adobe
          • 2. Re: Not working on my MacBook
            Kevin Goldsmith Level 3
            From your hardware description:
            Graphics: Intel GMA 950, GMA 950, Built-In, spdisplays_integrated_vram

            The MacBook doesn't have a compatible graphics card (the MacBookPros do). Unfortunately, this version of the toolkit will not work on your laptop.

            Still, we shouldn't be crashing. Did you get a warning dialog first? I'll file a bug.
            • 3. Re: Not working on my MacBook
              peter/w
              There seems to be a similar problem on Windows. I'm on a GeForce 4 MX, which does not seem to be supported either (I don't think it supports GLSL). When I try to launch newIDE, nothing happens, i.e. I don't get an error message or anything, the program just terminates.

              I tried to fix the problem by putting a mesa opengl32.dll (which I found online) into the AIR directory, but all that did was it made the application loader complain that the mesa opengl32.dll had no entry point for wglSwapMultipleBuffers(), so I don' t think it's possible to get newIDE to run on older cards that way.
              • 4. Re: Not working on my MacBook
                Kevin Goldsmith Level 3
                yeah, it isn't just the OpenGL 2.0 support that we need, it is also that the hardware supports certain operations, so it isn't a DLL issue (or we'd just install that DLL). This version of the toolkit actually runs the filters on your graphics card, so if your card can't run our filters, you should get a warning on startup. We should have a second release before the end of the year that will run filters on your CPU if your graphics card isn't supported.
                • 5. Re: Not working on my MacBook
                  RavenWorks
                  I'd like to confirm another incidence of 'AIF Toollkit' crashing under Windows.. In fact, it just hangs invisibly; no window ever appears, but my whole computer runs very slowly until I manually kill the newIDE process with the Task Manager.

                  (My computer apparently has a "Pentium D" processor; I have no idea if this is higher or lower than a Pentium 4.)
                  • 6. Re: Not working on my MacBook
                    Kevin Goldsmith Level 3
                    Do you know what graphics card you have?

                    Right click on the "My Computer" Icon on your desk top and select "properties" from the pop-up menu. Then, click on the hardware tab in the dialog box. Clock on the "device manager" button and then click on the "+" next to the "Display Adapters" item. It should list a video card there.
                    • 7. Re: Not working on my MacBook
                      Marco Secchi
                      I'd like to confirm that crashes also on my macBook... same error as ondadiluce
                      • 8. Re: Not working on my MacBook
                        Kevin Goldsmith Level 3
                        This version of the toolkit will not run on a MacBook, it uses the Intel integrated graphics. It will work on the MacBook Pros.
                        • 9. Re: Not working on my MacBook
                          Ni2J
                          quote:

                          Originally posted by: AIF Kevin
                          This version of the toolkit will not run on a MacBook, it uses the Intel integrated graphics. It will work on the MacBook Pros.


                          Thanks for help Kevin.
                          • 10. Re: Not working on my MacBook
                            RossRitchey Level 4
                            I would also like to confirm a non-open - same as RavenWorks. I click to open, and hear my computer start doing something, but no window ever appears. If I watch the task manager when I try to open, I see that the newIDE process appears for a moment (less than 1 second) before getting automatically killed.

                            Win XP SP2
                            P4 3.2GHz Hyperthreaded
                            1.5 GB RAM
                            NVidia Quadro FX 1400
                            • 11. Re: Not working on my MacBook
                              Kevin Goldsmith Level 3
                              That configuration should definitely work. I'll contact you privately and see what is going on. I'll post a message to the forum when we've figured out the problem.