4 Replies Latest reply on Mar 1, 2010 12:21 AM by Codefinger

    Error generating PHP sample service

    Codefinger Level 1

      Hi all,

       


      Running WinXP, FB4b2 (downloaded 210210), WAMP 2; Apache v2.2.11, PHP v5.2.9-2, MySQL 5.1.33.

       


      FB4 installed fine, only exception being the Zend framework prompted me to download the latest version of Zend once FB4 had installed an older version - I left it be, preferring to go with FB4's choice of framework.

       


      After creating a basic table in phpmyadmin and stepping through 'Connect to Data/Service', FB4 hangs for about 3-4 minutes (my system is fairy mean), and finally spits out "Fatal error: Maximum execution time of 30 seconds exceeded in C:\wamp\www\ZendFramework\library\Zend\Db\Adapter\Pdo\Abstract.php on line 147".

       


      MySQL table dump:

       

       

       

      FB4v2 error log, PHP log, my WAMP phpinfo file all attached but sorry couldn't find the log referred to by Shikha in post 21, "Step 2" @ http://forums.adobe.com/message/2009071#2009071.

       

      All help appreciated, keen to get this sucker up and running so I can explore - I'm all enthused after the Adobe REFRESH Roadshow in Auckland

       

       

      - danjah

        • 1. Re: Error generating PHP sample service
          sudhirm-rRcgag Adobe Employee

          Hi Danjah,

           

          I was able to successfully import the table, connect to db, and generate php service without any issues.

          Set the max_execution_time to a larger number (say, 120) in your php.ini, and check if that solves your problem.

           

          max_execution_time = 120 ;

           

          Thanks,

          Sudhir

          • 2. Re: Error generating PHP sample service
            Codefinger Level 1

            Hi Sudhirm,

             

            Thanks for your reply, I gave that a shot, initially boosting it to 120 as suggested. I got the same error after 120 passed, the FB4 error duly noted that the length of time had expired (it said 120 instead of the old 30). So I then tried at 360. I also went to bed

             

            When I woke up in the morning, the error was thusly:

             

            Server error SQLSTATE[HY000] [2013] Lost connection to  MySQL server at 'reading initial communication packet', system error: 0

             

            Any further thoughts? I thought maybe on the off-chance that my quals were awry, I tried every flavour of username/login to access my mysql db (reason being I didn't have u/p set up, but do now), but it's definately 'admin' and 'password'.

             

             

            - danjah

             

             

            [[Edit]]

             

            After further testing, and running through these steps on another machine (XPSP2, WAMP2, FB4b2), I got the same results; first the timeouts, and then the error after increasing the max execution var to 360. I really, really don't want to use my time debugging database tables or php configurations - I just want to get busy with some cool stuff. So if anyone has a wicked link that can help give me a crash course in debugging this stuff quickly, or any suggestions, I'm offering a free beer if you travel to Wellington

             

            [[Edit]]

            Not providing a port number in the mysqli call allows connection, I'm guessing my mysql program is not listening to port 80?

            • 3. Re: Error generating PHP sample service
              sudhirm-rRcgag Adobe Employee

              3306 is the default MySQL port number. You should specify this as your server port, unless your server is listening to a different port

               

              -Sudhir


              • 4. Re: Error generating PHP sample service
                Codefinger Level 1

                Bingo. Sometimes it's the little things, thanks for the lesson in debugging sudhirm, I needed it!