1 Reply Latest reply on Feb 22, 2010 3:09 PM by wingmann13

    SWF doesn't play with alpha channel

    wingmann13

       

      I have a 500Kb FLV file that plays as a progressive download through a 12Kb SWF. This FLV was encoded using On2 VP6 codec to maintain alpha data. This is a logo animation for a website so it is essential that the video plays with alpha channel intact. Just to make sure my animation had an alpha channel, I brought it into After Effects to test with a colored background behind it and sure enough, the alpha channel was there, perfect!

       

      Now in Dreamweaver, when I tested, the FLV plays through the SWF, as it should. However, there is a white square around my video now and the alpha channel is lost.

       

      I even made sure to select Wmode "transparent" and double-checked my code and saw that I had the correct tag <param name="wmode" value="transparent"/>

       

      View my site at http://www.customchromefx.com

       

      I have played many embedded SWF's with alpha's before. I think the FLV still has the alpha, and the problem is in the SWF that plays the FLV that is giving me the white box? Is there a way around this, perhaps a transparent SWF player or something? Thank you for viewing...

        • 1. Re: SWF doesn't play with alpha channel
          wingmann13 Level 1

          Okay, so I figured out a way to make my compressed FLV video play with alpha.



          I imported into Flash. Checked the box to "Embed FLV in SWF" and clicked next, and Finish. I made sure the stage area and FPS was set to the same settings as the FLV video.

          In publish settings I used Flash 9,then un-checked compress movie and Published. This new SWF maintained the same file size as the FLV, while also playing with the alpha channel.

          I then imported the SWF into Dreamweaver, and set Wmode to "transparent." 

          I now have a 45 second video (originally a 115Mb quicktime) squeezed down to a measly 500Kb SWF that also has an alpha channel. Sweet!