3 Replies Latest reply on Feb 25, 2010 4:02 PM by snorky

    Please Fix Floating Document Window Maximize Bug

    snorky Level 1

      When you maximize a floating document window you expect it to stay within the confines of the containing program so you continue to have access to the tools. But CS4 handles this differently. If you maximize a floating document window it completely covers the Photoshop window. I believe this is a bug because of the inconsistency with other software, inconsistency with past versions of PS and, while the document window is maximized, your cursor incorrectly stays "stuck" to whatever tool you were using even when you mouse over the title bar of the maximized document window!

       

       

      Here is the workaround we are using in our office,

       

      When we want to work with a document un-tabbed we drag its tab into the workspace and it reverts to a floating window. Then when we wish to "maximize" it yet keep all of our Photoshop menus, toolbars, etc. visible we drag it to the Options toolbar until it fades out and release it there. It reverts to a tabbed interface BUT it properly sizes itself within the Photoshop workspace. Drag it back into the workspace and it reverts back to a floating window.

       

      We have found that once we get used to it it works just like before only instead of using the Max button on a document we drag it to dock it. And instead of using the Restore button on the document we drag it again to undock it.

       

       

      BUT, it would be better if Adobe fixed this annoying bug!

        • 1. Re: Please Fix Floating Document Window Maximize Bug
          Reynolds (Mark) Level 4

          Snorky - assuming you are using macs because you have used the word 'maximize'? Or are you talking about PC's interface ?

           

          Its likely that you are just not realising that there are many features and options that wil help. Try these…

           

          • Window > Application Frame - turn this OFF. On mac

           

          • Preferences > Interface > Open documents as Tabs - turn this off also.

           

          • The F key on your keyboard will set the window to Full Screen Mode. This is the most useful of all Photoshop screen modes and is used by most people in professional retouching. It eliminates the need for the nailed to the edges, Windows style Application Frame completely.

           

          • Shortcuts are an essential part of professional Photoshop use. If you are employing people who have failed to learn these simple things, then in the humblest possible terms of course, I suggest you take them into a small office and hit them over the head with a copy of the Photoshop 5 manual. Command (or control) 0 - command alt 0 - will maximize the document to available screen space. View > Fit On Screen - or double click the zoom tool in the tools bar

           

          • The Tab key toggles tools and panels

          • 2. Re: Please Fix Floating Document Window Maximize Bug
            snorky Level 1
            Snorky - assuming you are using macs because you have used the word 'maximize'?

             

            nope. you assumed wrong! we are using PCs.

             

            Its likely that you are just not realising that there are many features and options that wil help.

             

            its likely you did not read (or understand) my post. this is not about "features and options" this is about functionality that has changed in CS4 and in my humble opinion, functionality that is not incorrect.

             

            • The F key on your keyboard will set the window to Full Screen Mode. This is the most useful of all Photoshop screen modes and is used by most people in professional retouching. It eliminates the need for the nailed to the edges, Windows style Application Frame completely.

             

            The F key does indeed maximize the document window BUT it maximizes it UNDER the toolbars! Better than using the document window maximize button I'd agree but still strange behavior.

             

            • Shortcuts are an essential part of professional Photoshop use.

             

            Duh!

             

            Command (or control) 0 - command alt 0 - will maximize the document to available screen space. View > Fit On Screen - or double click the zoom tool in the tools bar

             

            On a PC this is Crtl+0....and it does NOT replace the maximize document window functionality I am requesting. Rather, it changes the window size and the zoom level to fit it inside the workspace. Not what I am requesting.

             

             

            Thank you for your post but you should not automatically assume that the person you are answering is not as smart as you...sometimes it just ain't that way! Cheers.

            • 3. Re: Please Fix Floating Document Window Maximize Bug
              snorky Level 1

              I said,

               

              in my humble opinion, functionality that is not incorrect.

               

              but I meant,

               

              in my humble opinion, functionality that is not correct