1 Reply Latest reply on Feb 27, 2010 11:13 PM by CHowells

    DRMed PDFs don't show on Touch eReader but EPubs do...

    CHowells

      I download ebooks from my local library. I use ADE to manage my borrowed books. It has worked fine in the past with both epub and pdf formats. Today I downloaded a new book that was in pdf format. When I used ADE to move it to my Reader (Sony Touch eReader PRS-600) I couldn't get it to show properly. When I open it, it says "Protected Page!". I have 4 books in total out right now, 3 pdfs and 1 epub. Now, none of the pdfs work on the Reader, only the epub. I am able to see them fine on my computer in ADE and in Sony's Reader Library. In the book list on the Touch eReader it shows the epub as having an expiry date but not the pdfs. In ADE it shows all 4 books as having an expiry date.

       

      So far I've tried the following:

      1. Deleted and recopied the books from the computer to the eReader
      2. Re-installed Sony Reader Library
      3. Re-installed ADE
      4. Unauthorized and re-authorized my Sony Touch eReader

       

      All this started happening today when I copied one of the pdfs over to the eReader.

       

      Any suggestions on how to fix this?

        • 1. Re: DRMed PDFs don't show on Touch eReader but EPubs do...
          CHowells Level 1

          I found a way to fix this. When I tried using Sony Reader Library instead of ADE I noticed that the expiry times were showing for all 4 books in the book list on the eReader. It still showed the error message when I tried to read the pdfs on the eReader so I unauthorized and re-authorized the eReader again using Reader Library to install the books. That seems to have worked as I can now see all the books properly in my eReader.