6 Replies Latest reply on Feb 16, 2011 1:46 AM by beijingxi

    Chart Linear Axis's title(Description) is not displaying chinese words!

    Skygenetic

      Recently on my project's end there is a need to translate the current english web portal to chinese web portal . In the middle of the transition , i found that i had a difficulty to replace the Linear Axis description with chinese words , the initial code i had use to declare the english version linear axis description  is shown as below:

       

      <mx:verticalAxis>                                                

      <mx:LinearAxis labelFunction="linearAxis_labelFunc" title="Population" displayName="Population">                   

      </mx:LinearAxis>

      </mx:verticalAxis>

       

      Then i replace the chinese words into the title and displayname , and this should be a very straight foward change. Eventually when i compile and run , the chart's linear axis doesnt shows up any words at all .

       

      for testing purpose , i had actually try to insert the chinese words in between the english words example:

       

      <mx:verticalAxis>                                                

      <mx:LinearAxis labelFunction="linearAxis_labelFunc" title="P(Chinese words here)opul(Chinese Words here)ation" displayName="P(Chinese Words here)opul(Chinese Words Here)ation">                  

      </mx:LinearAxis>

      </mx:verticalAxis>

       

       

      Eventually the results only shows the description " Population ",

       

      I had try to drag the chart to be way more larger to see if there is an alignment problem on the description, but still the chinese words is not appearing. So far i had no problem in inserting the chinese words into the panel title , label , and other table axis . I only have problem on the CHART'S LINEAR AXIS DESCRIPTION. it seems like the compiler is ignoring it !  i am currently using Adobe Flex Builder 3 Professional . Please Help me ! This is Urgent !