7 Replies Latest reply on Mar 3, 2010 9:14 AM by DC B. 09

    Particular 3D effect gets clipped off

    DC B. 09 Level 1

      Hi:

       

       

      The best way to illustrate what happens is to show this screenshot (see attached). In a nutshell I have a comp with a Trapcode Particular effect applied to a solid layer in it. All layers in that comp are set to 3D. I also created a camera for it. When I insert that comp into another 3D comp with it's own camera, the effects of the Particular get cut off at the edges of the comp (like it's shown in the screenshot). I tried using Collapse Transformations and 3D on/off switches for this layer but it doesn't seem to work. Can someone suggest what am I not doing right?

      trapcode.JPG

        • 2. Re: Particular 3D effect gets clipped off
          Andrew Yoole MVP & Adobe Community Professional

          Depending on what you're trying to achieve, you should probably move the Particular layer into your main comp - otherwise, it won't react to your main comp's camera in true 3D - it'll only ever be a flat plane containing the pre-comp the way you're doing it now..

          • 3. Re: Particular 3D effect gets clipped off
            Rick Gerard Adobe Community Professional & MVP

            Particular should be applied to a 2D layer the same size as your comp. The particles will interact with the camera (with the right settings) and other 3D layers. All you have to do is to turn off the 3D.

            • 4. Re: Particular 3D effect gets clipped off
              DC B. 09 Level 1

              Thank you, guys. I understand that it will not be a "real" 3D. My main concern was to get rid of the clipped edges. I was able to solve it by increasing the size of the first comp, which wasn't easy because of all my keyframes in it. I was looking for an effect to do it automatically but evidently Particular doesn't obey Grow Bounds as suggested above.

              • 5. Re: Particular 3D effect gets clipped off
                Rick Gerard Adobe Community Professional & MVP

                Particular is a 3D effect, the camera will fly through the particles, and it will behave more like a true 3D object that regular layers. The catch is that is should be applied to a 2D layer. It would be highly unusual for a plug-in that simulates 3D space to be applied to 3D layer. Trapcode Form, 3D stroke, CC Cylinder, etc., are all designed to be used on a 2D layer. Many of these types of plug-ins will give you a warning if you attempt to apply them to a 3D layer.

                 

                If you have a pre-comp that contains particular and other 3D layers then you should still obey this rule. A camera and lights in the main comp will interact with 3D layers in a pre-comp if you collapse transformations. The usual practice is to only have a camera in your main comp. It is generally not a good idea to change the pre-comp to a 3D layer.

                 

                There are times when you will want to break these rules, but they are rare.

                 

                Judging from what you said about increasing the size of the first comp I'm guessing that the first comp and the main comp are different sizes. If that is the case you could have solved your problem by increasing the size of the layer used for the Particular effect to the same size as the main comp, keeping that layer 2D and collapsing transformations for the pre-comp layer. If the first comp and the pre-comp are the same size all you have to do is to make the Particular layer 2D.

                • 6. Re: Particular 3D effect gets clipped off
                  RaycerX Level 1

                  From the picture above it looks like the layer Particular is on isn't the same size as your comp. They both need to be the same size.

                   

                  Also, make sure to move the Particular effect from within Particular's settings. It looks like you're moving it around from the position settings in the layers palette.

                  • 7. Re: Particular 3D effect gets clipped off
                    DC B. 09 Level 1

                    No, guys, both layers were the same size (on that screenshot). It looked like the precomp was smaller because it was pushed back on the z axis and the camera had depth of field applied to it.

                     

                    As to what Rick Gerard said, then I did have a Particular effect applied to a 2D layer in the precomp in the first place, but it was still clipped off at the edges in the main comp (even with collapse transformation check on). That's when I started experimenting and made it 3D. Again, as I said it probably had something to do with the way Particular works, since it's a third-party plug-in. As I said increasing the size of the pre-comp to something like, 2 times larger than the main comp fixed the issue of cropped edges.

                     

                    Thanks for your insight again....