6 Replies Latest reply on Mar 4, 2010 10:57 AM by frazzled123

    Double Spaced PHP?

    frazzled123 Level 1

      When I download my PHP files from the server they are all double spaced? After editing and uploading it causes the site to malfunction. I've tried to look for solutions to no avail. I tried editing the FTPExtensionMap.txt file to PHp files to binary. That didn't work.

      Then I tried line break type under preferences set that too (UNIX), that didn't work. I manage several sites and some are windows servers and some are LINUX. Any help?

      Thanks

        • 1. Re: Double Spaced PHP?
          00rDog Level 1

          Php files should be transferred as ascii.

           

          Set the line break type to your Dreamweaver computer OS type (Win/Mac).

           

          HTH

           

          -Rb

          • 2. Re: Double Spaced PHP?
            frazzled123 Level 1

            I didn't seem to have the problem when the site was hosted on a windows server, but it is now and will remain on a LINUX server (I will also add that the site was supplied to the host in a zip file and they propogated it and I then downloaded it from the server to my local files, however they claim on their end the files are not double spaced only after I download it did it come in as double spaced. My orginal files were not double spaced)

             

            In CS4:  Preferences/Code Format/Line Break Type Choices are;

            CRL LF (Windows)

            CR (Macintosh)

            LF (Unix)

             

             

             

            I am on a PC and have it set to: CRL LF (Windows) and have set the FTPExtensionMap.txt file to PHP = ASCII

            Thoughts????

            I can't edit the site ntil it is resolved.

            Thank You.

            • 3. Re: Double Spaced PHP?
              David_Powers Adobe Community Professional

              frazzled123 wrote:

               

              I am on a PC and have it set to: CRL LF (Windows)

              Set it to LF (Unix). I work on Windows, but host on Linux. That setting works just fine.

              • 4. Re: Double Spaced PHP?
                frazzled123 Level 1

                I tried changing to  (Unix) setting and downloaded the file again. Still double spaced?

                I hate to have to buy a new ftp editing program for one site. (I mange several sites)

                • 5. Re: Double Spaced PHP?
                  00rDog Level 1

                  Have you tried creating a brand new file with the spacing you wish, uploading it, then downloading it?

                   

                  Since you mention that the files came from a Windows server and were extracted on a Linux server

                  it is certainly possible, that the CR LF was not interperted correctly on the files now existing on the

                  Linux server.

                   

                  In this case I would unzip the site to your local machine then upload the files.

                   

                  FYI: also, Filezilla and WinScp are two great open source file transfer programs.

                   

                  HTH

                   

                  -Rb

                  • 6. Re: Double Spaced PHP?
                    frazzled123 Level 1

                    You might have something there.. I created a new file, uploaded it, deleted it locally, and downloaded within CS4 and it didn't have double spaces!

                    Not sure how this happened because the hosting company has downloaded the files and they are not double spaced for them.?? Perhaps the translation with zipping the file??

                     

                    At least I have something to try to fix.

                    Thank You