2 Replies Latest reply on Mar 4, 2010 11:12 AM by Hube02

    auto indent


      Just installed CS4 and only because I had to, I had an HDD crash and could not find my copy of DW8. I can tell you that I am NOT happy.


      Why is it that the developers of applications insist on thinking that they are smarter than I am and that I need them to decide for me how to write code.


      The most anoying feature is the "auto indent" I don't mind that it automatically indents to the same level when I hit enter, but deciding form me that the next line MUST be indented and how far when I hit { ( [ etc... is pissing me off. Can someone tell me how to disable this stupid F'n feature. I have edited my preferences over and over again, DW seems to remember this for a document or two and then I am right back to having it on again. WTF. If it wasn't for the features I depend on, namely FTP, syncronization, and auto complete of tags I would unintall and use the CD for target practice.


      CLUE: You are not smarter than I am!

      CLUE: You cannot produce a application that is smarter than I am!

      CLUE: Give me a way to permanantly disable the stupid F'n features that I don't want!

        • 1. Re: auto indent
          Nancy OShea Adobe Community Professional & MVP

          This is a user-to-user support group.  Swearing, ranting and raving won't do you much good here.


          Edit > Preferences >  Code Format.  Deselect Indent box.  Set Tab space to 1. Hit OK.


          To remove indents in code view, hit Ctrl+A to highlight all your code.  Hit Ctrl+Alt+ [ as many times as required.


          Does this help?


          Nancy O.
          Alt-Web Design & Publishing
          Web | Graphics | Print | Media  Specialists

          • 2. Re: auto indent
            Hube02 Level 1

            Sorry for the rant here, I'd love to rant at Adobe, but I have not  found a way to do so. Seems like they are not really interested in what  they're users think.


            I have tried "Edit > Preferences >  Code  Format.  Deselect Indent box.  Set Tab  space to 1. Hit OK."


            This does not help. The samrt  indenting still works I don't know what effect this setting has, but no  matter what it is set to when I hit { [ ( > the next line always gets  indented and depending on what type of code I'm working on, this indent  is different. (php, asp, cf, html, javascript)


            As far as removing all the indenting completely, this  is not what I want to do, I just want to control the level of indent  myself without some AI deciding for me how it should be done. That is  why God invented the space bar (or the tab key if you like it better).


            With  the number of other places I found on the web that discusses this same  stupid issue you'd think that Adobe would put some effort into giving us  a way to completely disable their "I'm smarter than you are" features.


            Yes,  I'm still ranting but it does make me feel a little better that someone  somewhere will read it.


            Time for me to sart looking seriously at finding something better I guess, I just feel that with the amount of money they soked out of me that it would work or at least give me the ability to disable those features that I don't want.