4 Replies Latest reply on Mar 15, 2010 6:52 AM by -Matthew-

    CFIMAP

    -Matthew-

      I'm a having a problem with spaces in folder names with CFIMAP, any suggestions? besides remove the space

       

      Parameter 1 of function SetVariable, which is now - PS Beta 6, must be a syntactically valid variable name.

       

      Thanks,

      Matthew

        • 1. Re: CFIMAP
          Adam Cameron. Level 5

          It's a bit difficult to say too much without seeing your actual code. 

          Looks like your problem is with a setVariable() call rather than a 

          call though. Speaking of which: whilst it still works, didn't 

          the need to use setVariable() go the way of the dodo with... CF4 or 

          something?

           

          --

          Adam

          • 2. Re: CFIMAP
            -Matthew- Level 1

            <cfimap

            action="GetHeaderOnly"

            connection="serveraddress"

            name="queryname" maxrows = "10" folder="#url.name#" >

            • 3. Re: CFIMAP
              Fernis Level 3

              It's still not the cfimap that causes the error in my opinion, but obviously you're using SetVariable somewhere else - and having problem with that.

               

              CFIMAP works for me just fine with space in folder names (tested with gmail)

               

              <cfimap port="993" secure="true" connection="myg" username="spaceball" password="12345"
              action="open" server="imap.gmail.com">

              Opened OK

              <cfimap connection="myg" action="getheaderonly" name="mh" folder="mega maid">

              Fetched OK
              <cfimap action="close" connection="myg">

              Closed OK

               

              (username/password/folder *are* (sci-)fictionary, although they just might work )

               

              -Fernis

              • 4. Re: CFIMAP
                -Matthew- Level 1

                Erroneous error;

                 

                 

                i am almost 100% sure that the error you see has nothing to do with <cfimap> or spaces in folder names.

                 

                my [wild] guess is that you have
                <cfparam name="#url.name# ...> <----- This was the answer
                or something like this in your page.

                 

                the mistake here is using # in the name attribute of cfparam tag - remove them and everything should work.

                 

                check this post by Ben Nadel for the same error you see: http://www.bennadel.com/blog/1436-Parameter-1-Of-Function-SetVariable-Which-Is-Now-FORM-Mu st-Be-A-Syntactically-Valid-Variable-Name.htm

                 

                PS: <cfimap> has no problems accessing folders with spaces in name.