3 Replies Latest reply on Nov 14, 2007 8:20 AM by Newsgroup_User

    Director & Preload AVI video

    Level 7
      Hi,

      I have a problem when I import a AVi file in my Director PRoject, because
      always a black frame appears before loading the video, though the video
      doesn't take it.

      Exists some way of doing a preLoad of the video before watching it?

      Thanks, and sorry for my English


        • 1. Re: Director & Preload AVI video
          dsdsdsdsd Level 1
          obvious question: is the black frame related to the sprite?
          • 2. Re: Director & Preload AVI video
            Applied CD Level 1
            Here’s a possible low-tech solution: Start the video sprite off stage in frame X, move it into the proper position in frame X+1. This wouldn’t prevent the black frames you’re describing but the user wouldn’t see them. You might want to start the video paused (playrate=0) and then un-pause (playrate=1) in frame X+1, although I doubt it’s necessary.
            • 3. Re: Director & Preload AVI video
              Level 7
              Tony Angel wrote:
              > Hi,
              >
              > I have a problem when I import a AVi file in my Director PRoject, because
              > always a black frame appears before loading the video, though the video
              > doesn't take it.
              >
              > Exists some way of doing a preLoad of the video before watching it?

              You can preload the cast member by cast member property (the palette) or
              by lingo.
              You can also try this trip:
              - put the AVI outside the stage
              - go to the next frame and change sprite loc moving the AVI into it's
              position

              In this way the hiligth will be outside the stage (not visible).

              hth
              asleo